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From the Chief Editor's Desk

Papawoob

Hello everyone and welcome to our 15th issue! |
am sad to say that you will be viewing the last
chapter of the KDE User Guide. It has been a
labor of love for me, but | am doing a little editing
and hope to have the whole thing available as a
PDF download that will be available at both the
main PCLinuxOS home page and the
Magazine's home page.

We have some interesting articles this month
including the Linux Command Line Tutorial which

will give everyone a taste of using the command line safely. This was
modified from an original text that was written by the Texas A&M Statistics
department. We also have the Linux Directory Structure which will attempt to
describe a little about each of the mysterious directories that you have seen,
but are totally clueless as to what they contain. You will also find a couple of
useful tips that will help speed up your computing experience.

Looking forward to next month, we will be bringing you a howto on DVD's
and another on multi-booting on multiple drives. You will also find more
command line articles along with a requested article or two. Speaking of
requested articles, if any of you readers have an idea for an article that you
would like to see, please give us your requests at either the main forum or at
the Magazine's forum. As always, you can always contact me with anything
about the Magazine at: papawoob@pclosmag.com.

See y'all next month!

Papawoob




Letters to the Editor

Papawoob
Looks pretty much like pc world layout. I'd prefer the previous layout.

Thanks anyway coz it's as informative.

lan Tan

Hi. | just want to say, 1. I'm not a low bandwidth user but I'd

much rather read the magazine online than download a file and open it in
a pdf reader. Reading pages in the browser is so much more convenient.
I've also bookmarked a number of articles on my private wiki site.
Bookmarking is another reason for preferring an html version. Thanks for
all the fish. 2. Why do you need a separate forum? Why not a board on
the distro forum? cheers.

Regards, Terry North

Thanks for writing Terry. We create two versions to give our readers as many options as possible. Also, we have a
forum because we expect a considerable amount of traffic and we can create as many sub-sections as necessary
So as to make it as easy as possible for the staff to follow and react to anything that is posted.

Papawoob

Hi PCLOS Team!

First of all let me wish You a very big congrats for giving the Linux Community such an wonderful distribution. |



have seen and used many Linux distributions, but nothing came close to PCLOS in terms of usability, stability,
speed, responsiveness and aesthetics. | have become a diehard fan of this distro which | am sure will take the
Linux desktop world by waves. | am a full time Systems Administrator working for an well established and popular
MNC and specialize in Unix ,Linux admin, middleware, Oracle dba, application servers and client-server
technologies. | am telling you this so that you don't take Me for a newbie who is on a flattering drive of this distro.
VMware on this distro runs Windows XP as guest OS as a charm. There is this simple test which can tell you a lot
about a distro .Install vmware on pclos, created a Windows xp as guest os ,allot 400 mb physical RAM (My
machine has 768MB RAM), start the virtual machine, start simultaneous downloads in the host and guest os of a
huge file, then surf web in mozilla on the host os, listen to mp3 songs in Amarok, chat in pidgin, use calendar, play
games. | did all these things mentioned and the distro was still rock solid, fast, responsive, and still not hogging
the memory. It still amazes me....In all these years of trying so many distros , | have never, ever seen a Linux
distro (meant for desktops) perform those tasks so smoothly. One more thing, | loved about it was its out of the
box capabilities.

| recently, ordered a Dell Inspiron 1420 laptop (waiting for it to be shipped) and am aware that Dell has released a
remastered Ubuntu 7.04 such that it runs flawlessly on this machine. But, | would like to stick with PCLOS 2007
on this new machine. | hope, it would run out of the box on this machine too and prove itself once again as an
Emerging Star Distro in the Linux World.

| have some suggestions for the PCLOS team:

1) Please please please,improve your website. PCLOS is a great OS, but it isn't being shown to the world
properly.

2) Publish a list of laptops which are supported or certified to run PCLOS2007

3) Bump up your wiki pages.

4) Build a strong PCLOS community ,which will fuel your marketing goals.

5) | would love to distribute PCLOS media in My region and spread it...Is there anything in place for such
distribution purposes?

Thanks once again!!!

Yours PCLOS 2K7 Fan!

Thanks for the awesome review!

1)We are always open to suggestions about improving our websites. You can make any suggestions you may

have in "Site Suggestions"” on the main forum or at the Magazine website forum.
2)We are building a hardware database which will list most hardware that works and some that does not work.



3)We have a wiki team in place that is working on bringing everything up to date. It is quite a lot of work.
4)I think we have a very active community demonstrated by the successes at Mypclinuxos.com and the fact that

forum registration has more than tripled in the last year.
5)] am not aware of any media such as you are requesting but will find out if we have any.

Papawoob
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Testimonials

While this is my first day with PCLinuxOS on my desktops, | have a feeling it will be on both for quite a while. |
have been looking for a Linux distro that would work on my wife's IBM Thinkcenter. It is an older computer into
which | have put a Belkin wireless card. She was using MEPIS, Ubuntu, and Kanotix for awhile....then disaster
struck. The old Sun Microsystems monitor that she was using died....and screwed up the integrated video port on
the motherboard. | bought a cheap video card to get her back up and running. The other distros didn't recognize it
and immediately dropped into CLI. Unfortunately, she isn't very CLI capable, and | don't feel like going through a
lot to configure the system again. | began to play with distros yesterday. | tried 6 or 7, all either didn't recognize the
video card or they presented problems getting the wireless to work. It was at that point that | tried your
PCLinuxOS.....all | can say is WOW. Everything was configured and up and running in minutes....not hours. |
subsequently replaced the MEPIS install on my desktop too. | have been Windows free for several years and have
used many distros: DSL, Xandros, RHEL 5 (which | never really got running well), SIDUX, Kanotix, MEPIS,
Ubuntu (and its siblings), SUSE, etc. Kanotix stayed with me the longest. It was easy to configure and was quite
stable. But, they quit updating it. Having all of this experience has given me a pretty good idea about what | look
for. Simplicity!!! | don't want to have to spend my time configuring the computer....I just want to use it. An
occasional tweak is fine....but, why can't things just work. Enter PCLinuxQOS...it just works. Much like OSX on my
MacBook, it is easy to use and | was up and running quickly. | guess Apple has spoiled me. Until | found this distro
| was looking at spending a great deal of money to get all Apple computers....money | don't really have. | wanted
my wife to have a computer she could just use without calling me every 10 minutes to fix something or explain
something. So far, this has done the trick. Thank you for all your hard work. This is the first non-Debian distro |
have tried in a very long time RHELS left a pretty bad taste in my mouth....SUSE too. Thanks again.

by alii1959

I'd also like to thank the team.

I'm a refugee from Xandros .. a distro that | used from version 1 through 4. I'm not going to trash Xandros here
(they are managing that quite well on their own) but | have to say | was getting a little unhappy with the
performance from Xandros even before the "deal with the devil". That incident just got me off my rear end and
looking "seriously" for a replacement distro .... so maybe | should thank them for that.



Xandros' claim to fame was it's "out of the box" simplicity. Frankly, you have them beaten on that one, and indeed
in just about every area.

I've checked out a lot of distros ... and continue to do so because | promote the use of Linux and people's needs
differ, so my assessment is based on testing a lot of very good distributions, and in my opinion this one is by far
the best. I've seen a lot of distros that run fine on a live CD but not installed (that one puzzles the hell out of me to
be honest), no such problems this PCLOS. | have installed this on 5 PCs now ... various ages and specs ... and it
just works. For those "older" machines around, MiniMe is fantastic.

So, PCLOS is now my first choice every time. This distro has given my laptop a whole new lease on life. It's a
Presario 2100CA with the a memory upgrade (1 gig) and it flies. Beryl is amazing .. considering this thing has
64meg shared video memory.

My webcam works fine .. something that | could never get to work in Xandros.
A truly great distro guys .... THANK YOU
regards to all,

Dave

Greetings forum participants and PCLinux 2007 developers:

Here's my story. | needed to migrate from XP for many reasons, including that OS's insecurity, fragility, bulk,
intrusiveness, cost and approaching obsolescence. Also, | travel on business, and my employer's increasingly
buttoned-down laptop policy made it likely I'd need to move my private email and personal files off that machine.
Rather than cart around two laptops, | wanted to run my "personal” stuff on a virtual machine that could be put on
a thumb-drive or portable USB hard disk.

So | started looking at the various distros of Linux. I'd tried Linux seven years ago and, while it was stable and
powerful, | hadn't been impressed with its day-to-day usability. Lately, what | heard about Ubuntu in particular
seemed promising. | read through their site thoroughly, it seemed their hearts were in the right place, and more
importantly their brains seemed dedicated to making a usable, complete and stable distribution that would do what
| wanted to do, and for the right price.



So | downloaded Ubuntu and installed it without trouble in a VMware virtual machine. Fine enough, but there were
several problems: first, | disliked Gnome, and getting my networked printer working took a lot of work including
several wrong turns. Still, figuring I'd get into the groove eventually, | forced myself to use Ubuntu by transitioning
one of my three personal email accounts to it; | continued to use XP on the others. | chose Evolution for email due
to its resemblance to Outlook, and Firefox was my choice for a browser.

Ultimately | found Gnome so limiting and clunky that | investigated KDE; the Ubuntu folks had promised it was
easy to switch from one to the other. Hah. | hosed my poor VM rather badly trying to get KDE installed, and it took
a lot of effort to get things working properly again. The printer (a high-end HP multifunction unit) never quite
worked right, either. On-screen, fonts looked noticeably coarser than | was used to in Windows. And throughout,
there was this odd mouse-key bounce problem that meant a rapid left-click would register as two separate clicks.
Though | tried to train myself to click with slow deliberation, my normal hastiness kept biting me, with two windows
popping up where one was desired, or even four if I'd rapidly double-clicked where | should have slowly single-
clicked. Also, | soon tired of Evolution and decided to try Thunderbird. Thunderbird was crashy, as was Firefox. If |
tried to leave Thunderbird up all the time as | had with Outlook, it would crash six or eight times during the course
of the day.

The crowning glory, though, came when | read about the wonders of Beryl. Lo, | found it was installed as standard
in Ubuntu! So | tried turning it on, and ...oh, such a mess. It brought my Ubuntu down with almost an audible crash
of cymbals. Eventually | got it working again, but Ubuntu (or, with its KDE installation, was it now Kubuntu?)
seemed (even) more fragile than before. Hm, maybe updating things in Synaptic would fix that? ...Nope, and now
Synaptic complained of irreconcilable dependency conflicts. How do you fix that?

Oh, and by the way, during my months of playing with Ubuntu, my sons expressed interest in trying Linux on their
old castoff Sony laptops, previously loaded with Windows 98 and ME, respectively. They'd moved to Mac laptops
several years ago, and those Macs have performed flawlessly for them, with not a single virus or malware problem
(vs. my having to wipe and reload their Windows laptops every few months due to contagions that had made it
past their costly virus checkers). So the old laptops were sitting around doing not much. Ideal playpens for Linux
curiosity.

Alas, Ubuntu would not work on these machines at all. When | attempted to install from a LiveCD, the kernel would
load, some drivers and stuff would churn and grind, then everything would freeze. No joy. Maybe Xubuntu would
work? Say, why not spend hours downloading and burning various flavors of an OS just to accommodate two very
common laptops? To heck with it. Back to the closet went those laptops.



At about this time, a correspondent recommended PCLinuxOS 2007. Not being a Linux fanboy, | hadn't heard of
it, but some googling suggested it was well-regarded. Okay, then:

It installed quickly and without issue into my VM. So far so good.

It recognized my printer! In fact, installing the printer was way less trouble than it had been in XP. No drivers to
download, no CD to stuff into the bay, nothing to configure. It. Just. Worked.

Wireless, wired ethernet, ditto. Sound, ditto. Everything. Just. Worked.

No more mouse double-bounce!

| like the look and feel. Fonts, in particular, looked better than in Ubuntu. I've made very few tweaks to the
system's standard configuration: the application-tray icons are now set to a smaller size, and | selected the Quartz

window-decoration theme with its Extra Slim option to help conserve precious pixels. That's it.

It had just about everything | wanted in the way of application software. (I'm still looking for an easy and
universally-compatible print-to-pdf capability like PDF995 for XP, though.)

Thunderbird doesn't crash nearly as often as it had under Ubuntu.

And I've yet to have a Firefox crash.

And, like Ubuntu, it has Beryl installed. But it's greyed-out, with a notation that my "hardware" (the VMware virtual
machine, which simulates a plain-vanilla PC) doesn't support the necessary 3D graphics routines. What a
concept: detect the user's hardware and lock out incompatible features to protect the system!

So | went cold-turkey altogether, switching my other two email accounts over to Thunderbird on PCLinuxOS 2007.

And much later I'm here to tell you: No regrets.

In fact, eventually | figured | had nothing to lose but a couple more hours' frustration if | tried installing PCLinuxOS
2007 on my boys' two Sony laptops. And [cue the dramatic music]: It. Just. Worked. Again!

In each case, | emerged (after perhaps twenty minutes of watching the automated installer do all the work) with a
spankin' fresh laptop sporting all the latest applications, running video without problem, on wired or wireless
networks, with sound, and all the rest of the best goodies. The video card works fine; the antique Netgear



PCMCIA 802.11b cards work fine; the mice and touchpads work fine.

Some googling suggests my success with the two Sony laptops is because Ubuntu is hard-core into the open-
source religion and lets not a single byte of proprietary code pollute its distros. If that policy means (for example)
that a particular video chipset is unsupported because the only available driver is proprietary, then you will have to
decide whether to install the proprietary driver or not. PCLinuxOS 2007, on the other hand, seems to be built to
work, and work seamlessly and automatically..

Impressive stuff. Recommended. In particular, if you are researching various distros before taking the plunge, you
can stop here with confidence.

by sjinsjca

Awesome review. PCLOS is a definite sleeper distro, but | think our little secret is slipping out. It's been number
one on distrowatch.com for a couple of weeks now. There is a server variant of it that was developed by a
separate group that works wonderfully for common server tasks such as file storage, print server, email server,
firewall, and a host of other tasks.

Like you with the old Sony laptops, | revived a dozen castaway Dells that were 5+ years old at my daughters
school, setting up a computer lab with those machines for the kids to use for both school related activities and
even gaming for their free time. | set the entire thing up for -$0-. The school administrator was thrilled, and after
about a week came a request from him to set up PCLOS as a dual boot on his laptop. And | must admit that even
| was surprised at both how easy the setup was, and how well it worked from the get-go.

| also revived an ancient 10 yr old Toshiba Protege laptop that had been gathering dust in my closet, with my
daughter now using it just as much as she does her 2 yr old XP desktop.

I’'m a Systems Admin for a Fortune 500 company, and an MCSE. I've always viewed Linux as a ‘hobby’ type OS,
but had firmly been a “Microsoft guy”. My brand new Vista Ultimate laptop now spends 80% of its time booted into
PCLOS, and when | don’t have it actually booted into PCLOS, a VM running it usually is.

PCLOS is, in my opinion, a real alternative to Vista or XP because it is both easy to install and maintain for the
beginner, and offers a high level of ‘tweakability’ for the advanced user.

Glad you like it, and I'm glad | was able to turn you on to it. | get a high level of satisfaction knowing that a simple



recommendation like that can be so useful to someone.

by the Correspondent

PCLOS on YouTube
MeeMaw

Many of us visit YouTube daily to see what new videos people have posted. | don't spend quite that much time
there, but | have enjoyed many of the demonstrations of Linux that I've seen. Recently, a young man named Chris
Gentry has posted a series of five episodes where he describes Linux and walks viewers through a look at
PCLinuxOS. One episode is about the desktop, another talks about Synaptic and another is specifically devoted to
Beryl. Each episode is very newbie-friendly, and Mr. Gentry has said there will be more episodes to follow.

ENJOY!IN!

http://www.youtube.com/user/gentrychris

Attention
Have you ever gotten tired of looking at those “Designed for Microsoft Windows” stickers on
your PC or laptop when you know it is “Powered by PCLinuxOS?” If you are like many other
PCLinuxOS users and myself, you can now do something about it. Thanks to the efforts of
Igross1949, and Gryphen (graphics), you can now order yourself as many as you need to
replace them, and every cent of profit goes to Tex & the Ripper Gang to help fund the
continuing development of our beloved OS. You can see what they look like to the right.

A il

—
PCLirux0S

You can order these by e-mailing Igross1949 at: Igross1949@yahoo.com or
Igross1949@powerc.net. After you have placed your order he will send you a billing
statement through PayPal and you can pay with Credit or Debit Card, or Checking Account.
You don't have to have a PayPal account to use it. They can be purchased for $4.00 US and
that includes shipping anywhere in the world. So let's get with it and order yours today!




Antec 900 Case Review
Trobbins

Like many people, I've never been able to afford the latest and greatest PC hardware. Most of the time, | do minor
upgrades one item at a time, until | reach that point where technology has made it impossible to continue with that
particular CPU and motherboard combination. Then | start the process all over. To get maximum bang for my
computer buck, | have always visited local small computer shops and purchased their products. As a result, |
almost never get anything in a box. The last CPU | bought was an AMD 2500+ that | paid (I think) about $50 for
when the same chip at CompUSA was just under $100. I'm pretty sure | bought a “cull” or “take-off.” All such chips
| have used over the years have run significantly hotter than was considered normal, no matter what | did in the
way of add-in fans.

My CPU has been running pretty consistently at 60 degrees Celsius, right at the upper limit for that chip. Nothing |
tried seemed to get it any cooler. Today, | decided to solve the problem. | visited my local CompUSA and
purchased an Antec model 900 case. Short story: problem solved and my CPU is now running at 40 degrees
Celsius. This is a case you should consider when investing in your next “build-it” project. The details follow.

Specifications:
Here are the specs, lifted directly from Antec's site at: http://www.antec.com/us/productDetails.php?ProdID=15900.

Unique Top mounted 200mm "Big Boy" TriCool exhaust fan to cool the hottest system
Perforated front bezel for maximum air intake

Two front loaded HDD cages for up to 6 hard disk drives

The HDD cages act as air ducts to take air in more efficiently. Optional middle 120mm fan bracket to cool the
hottest graphic cards or CPU

Two 120mm TriCool blue LED front fans to cool hard disk drives

Window side panel comes with an optional 120mm fan mount for maximum VGA cooling
Top tray for your MP3 player, digital camera, etc.

Power supply mounts at the bottom of the case (power supply not included)

Advanced cooling system:

- 1 top 200mm TriCool fan with 3-speed switch control

- 1 rear 120mm TriCool fan with 3-speed switch control



- 2 front 120mm special black TriCool blue LED fans with 3-speed switch control to cool HDDs
- 1 side (optional) 120mm fan to cool graphic cards
- 1 middle (optional) 120mm fan to cool CPU or graphic cards

9 Drive Bays

- External 3 x 5.25"; Internal 6 x 3.5" for HDD, or
- External 6 x 5.25"; Internal 3x 3.5" for HDD, or

- External 9 x 5.25"

Motherboard: Fits micro and standard ATX

7 Expansion Slots
Top mounted I/O ports

- Power & reset button with blue LED

-2xUSB 2.0

-1 x IEEE 1394

- Audio In and Out

Unit dimensions:

-19.4" (H) x 8.1" (W) x 18.4" (D)

-49.3 cm (H) x 20.6 cm (W) x 46.7 cm (D)

Package dimensions:
-21.5" (H) x 10.6" (W) x 21.1" (D)

- 54.6¢cm (H) x 26.9cm (W) x §3.6¢m (D)

Weight:
- Net: 18.52 1b / 8.4 kg
- Gross: 24.36 Ib / 11.05 kg

Making the Switch

| powered down my system and opened the case. Removed power supply,
hard drives and DVD drive and set them aside. (Note: NEVER stand a hard
drive on edge. Lay it down. If it tips over, your drive is trashed.) Then | located
my canned air and blew the dust out of the power supply and from around the
connectors on the hard drives. | removed the six screws that secured the
motherboard to the case and carefully lifted it out. Not having any anti-static
plastic, | placed it on a sheet of aluminum foil. | know, | might have shorted out
the CMOS battery, except that the first thing | do when | get a new board is to
apply a strip of electrical tape to the bottom of the board where those contacts



are.

Next, | removed the two memory boards and set them on the tinfoil. Again, the canned air did its job and cleaned
out the amazing amount of dust that accumulates in those connectors. | reseated the memory chips and moved to
the new case on my work table. First | installed the power supply and did a quick confirmation that the cables
would be long enough to reach.

Installing hard drives has always been problematic. It seems no case makers can quite agree on where the screw
holes should be. I've always wound up having to fight the case to get the screws into the drives, or have resigned
myself to using only two screws per drive. Not here. Antec brilliantly engineered the hard drive mounting system
into two 3-drive units that, once released from the case (thumbscrews, not those bitty ones | always manage to
drop), make installing the drives painless. The units are full-width, with an interior channel for each drive. Slide the
drive into place and secure with the long screws provided. Always be sure to use all four screws to secure your
drives. They hate being loose.




Once | had my three hard drives in the mounting unit, | slid it into the case from the front and re-secured it with the
four thumbscrews provided. A perfect fit. Each drive mounting unit has its own 120mm blue-LED fan in the front to
provide airflow over the drives. The front is perforated to facilitate airflow.

If you are not going to mount any drives in the other drive mounting unit, there is a plastic mount that can be
placed on the inboard end of that unit and a 120mm fan mounted there, so it runs in tandem with the fan in the
front. This is the “middle (optional) 120mm fan to cool CPU or graphic cards” mentioned in the specifications

above.

There are three full width bays above the two hard drive mounting units. | used one of these to mount my DVD
drive. If needed, | could have installed a floppy disk drive in another one. Antec provides a plastic adapter and a

front panel that matches the rest of the panels to accommodate the 3 1/2” drive.



Next | mounted my mini-ATX form factor motherboard. There were already standoffs in place to accommodate a
full size ATX. Antec provided a bag of hardware and | found the other spacer in that bag. Six screws mounted the
motherboard. | brought the power cable over to the connector on the motherboard and was afraid it would not
reach. The problem was that for the past year, the cable had been routed to that connector from the opposite
direction. It DID reach after | re-formed the wires a bit. It passes directly over my AGP video board, but that was
not a problem.

Now | hooked up cables. Each fan in the case comes with the standard four pin power connector used on hard
drives, so | daisy-chained them off one power supply lead. The connectors “stack.” Then | connected power
cables to four drives (three hard drives and the DVD drive). | plugged the signal cables into the motherboard and
then to the drives. | should point out that all the fans that come pre-installed have a short cable with a switch on
the end. This allows you to select any of 3 speeds. | put all the switches in the “fast” position (slide the button all
the way toward the END of the switch cable).

The cables from the “front panel” (which is actually located on top of the case) routed easily to their matching
connectors on the motherboard. It was nice of Antec to make the connector for USB into a single block connector.



Much easier to plug in than two thin plugs. | don't have Firewire on this motherboard, so | folded that cable up and
placed it out of the way. Antec provided tie-downs in the case to help route cables so they stay where you place
them. The only problem | ran into was reading the itty-bitty printing on the motherboard so | could tell where to
place the power, reset and HDD LED plugs. Its a shame that board manufacturers haven't standardized that
cluster of connections.

The Run-Up

Everything installed, side cover still off, it was time to test. If everything went well, | should have my system exactly
as before, except running a lot cooler. | pressed the power button and the fans began to spin, pretty blue LEDs
shining. The POST ran, and then bad stuff happened. The system couldn't find my drives. | went back to my notes
and discovered I'd placed both my slave drives on one channel, and therefore both masters on the same channel.
BIOS didn't like that. It took only a few minutes to redo my cables, and | powered up. Moments later, | saw the
familiar PCLOS boot screen, and then | was UP!

| immediately started GKRELLM to see what would happen with temperature. If you haven't looked at this little
application, please do. It can provide a good picture of what's happening on your system. Ambient in my living
room was 80 degrees Fahrenheit (26.7 degrees Celsius). | have circulation problems and am always cold, so |
feel comfortable at that temperature. My computers don't. | watched and waited.

After 30 minutes, temperature stabilized at 41 degrees Celsius, a 20 degree improvement! | did not purchase the
optional fan to fit inside the left side cover. I'll do that tomorrow. It sits directly above the AGP board, and of course,
that places its draft just below the CPU. Should help both devices to run even cooler.

In all the years I've been computing (and was able to check CPU temperature), | have always had to keep the left
side cover off to keep temperatures low enough. Finally, | can close my case.

Conclusion

Antec labels this as a Gamer's case. They are entitled to their opinion. In MY opinion, this is simply the best case
design | have ever used. It was well thought out to address common problems, notably, simplifying hard drive
mounting, extreme cooling, thumbscrews where they are most usable, and good looks. | love the controls being
on top where these tired old eyes can see them, and | don't have to bend over to hit power or reset. There is a
nice tray rear of the control panel that can hold things like my MP3 player; Antec provided a textured rubber pad to
sit in the bottom of that tray so things don't slide around.



What do | like about this case? Pretty much everything. What do | dislike? Well, Im messy. For many years I've

piled stuff on top of my computer; note pads, cell phone, junk. Now | can't do that; it would block that massive fan
on the top of the case. Never mind; I'll deal with that!

At $139 USD locally, this is not a cheap case. You can still get “plain Jane” cases for a lot less. But, in my opinion,
it's worth every penny. | purchased from a local store. If you hunt on line, you may find this case for less, but be
sure to figure in the shipping when comparing prices.

Now | have a not so hot computer.



Linux Directory Structure
Nana Langstedt

For more interesting articles by Nana please visit the Tuxfiles website.

As you may have noticed, Linux organizes its files differently from Windows. At first glance, the directory structure
may seem illogical and strange, and you may have no idea where all the programs, icons, config files, and others
are. This tuXfile will take you on a guided tour through the Linux file system. This is by no means a complete list of
all the directories on Linux, but it shows you the most interesting places in your file system.

</ >

The root directory. The starting point of your directory structure. This is where the Linux system begins. Every
other file and directory on your system is under the root directory. Usually the root directory contains only
subdirectories, so it's a bad idea to store single files directly under root.

Don't confuse the root directory with the root user account, the root password (which obviously is the root user's
password), or the root user's home directory.

< /boot >

As the name suggests, this is the place where Linux keeps information that it needs when booting up. For
example, this is where the Linux kernel is kept. If you list the contents of /boot, you'll see a file called vmlinuz -
that's the kernel. This is also where you will find your bootloader (Grub or Lilo) and any related files.

< /etc>

The configuration files for the Linux system are kept here. Most of these files are text files and can be edited by
hand. Some interesting stuff in this directory:

/etc/inittab

A text file that describes what processes are started at system bootup and during normal operation. For example,
here you can determine if you want the X Window System to start automatically at bootup, and configure what
happens when a user presses Ctrl+Alt+Del.

/etc/fstab

This file contains descriptive information about the various file systems and their mount points, like floppies, CD-
ROMSs, and so on (we covered this in the last issue).

/etc/passwd

A file that contains various pieces of information for each user account. This is where the users are defined.

< /bin, /usr/bin >

These two directories contain a lot of programs (binaries, hence the directory's name) for the system. The /bin



directory contains the most important programs that the system needs to operate, such as the shells, Is, grep, and
other essential things. /usr/bin in turn contains applications for the system's users. However, in some cases it
really doesn't make much difference if you put the program in /bin or /usr/bin.

< /sbin, /usr/sbin >

Most system administration programs are stored in these directories. In many cases you must run these programs
as the root user.

< /usr >

This directory contains user applications and a variety of other things for them, like their source codes, and
pictures, docs, or config files they use. /usr is the largest directory on a Linux system, and some people like to
have it on a separate partition. Some interesting stuff in /usr:

/usr/doc

Documentation for the user apps, in many file formats.

/usr/share

Config files and graphics for many user apps.

/usr/src

Source code files for the system's software, including the Linux kernel.

/usr/include

Header files for the C compiler. The header files define structures and constants that are needed for building most
standard programs. A subdirectory under /usr/include contains headers for the C++ compiler.

/usr/X11R6

The X Window System and things for it. The subdirectories under /usr/X11R6 may contain some X binaries
themselves, as well as documentation, header files, config files, icons, sounds, and other things related to the
graphical programs.

< /usr/local >

This is where you install apps and other files for use on the local machine. If your machine is a part of a network,
the /usr directory may physically be on another machine and can be shared by many networked Linux
workstations. On this kind of a network, the /usr/local directory contains only stuff that is not supposed to be used
on many machines and is intended for use at the local machine only.

Most likely your machine isn't a part of a network like this, but it doesn't mean that /usr/local is useless. If you find
interesting apps that aren't officially a part of your distro, you should install them in /usr/local. For example, if the
app would normally go to /usr/bin but it isn't a part of your distro, you should install it in /usr/local/bin instead.
When you keep your own programs away from the programs that are included in your distro, you'll avoid confusion
and keep things nice and clean.

< /lib >

The shared libraries for programs that are dynamically linked. The shared libraries are similar to DLL's on
Windows operating systems.



< /home >

This is where users keep their personal files. Every user has their own directory under /home, and usually it's the
only place where normal users are allowed to write files. You can configure a Linux system so that normal users
can't even list the contents of other users' home directories. This means that if your family members have their
own user accounts on your Linux system, they won't be able to see any of the files you keep in your home
directory.

< /root >

The superuser's (root's) home directory. Don't confuse this with the root directory (/) of a Linux system.

< /var >

This directory contains variable data that changes constantly when the system is running. Some interesting
subdirectories:

/var/log

A directory that contains system log files. They're updated when the system runs, and checking them out can give
you valuable info about the health of your system. If something in your system suddenly goes wrong, the log files
may contain some info about the situation.

/var/mail

Incoming and outgoing mail is stored in this directory.

/var/spool

This directory holds files that are queued for some process, like printing.

< /tmp >

Programs can write their temporary files here.

< /dev >

The devices that are available to a Linux system. Remember that in Linux, devices are treated like files and you
can read and write devices like they were files. For example, /dev/fd0 is your first floppy drive, /dev/cdrom is your
CD drive, /dev/hda is the first IDE hard drive, and so on. All the devices that a Linux kernel can understand are
located under /dev, and that's why it contains hundreds of entries.

< /mnt >

This directory is used for mount points. The different physical storage devices (like the hard disk drives, floppies,
CD-ROM's) must be attached to some directory in the file system tree before they can be accessed. This
attaching is called mounting, and the directory where the device is attached is called the mount point.

The /mnt directory contains mount points for different devices, like /mnt/floppy for the floppy drive, /mnt/cdrom for
the CD-ROM, and so on. However, you're not forced to use the /mnt directory for this purpose, you can use
whatever directory you wish. Actually, in some distros, like Debian and SuSE, the default is to use /floppy and
/cdrom as mount points instead of directories under /mnt.

< /proc >

This is a special directory. Well, actually, /proc is just a virtual directory, because it doesn't exist at all! It contains
some info about the kernel itself. There's a bunch of numbered entries that correspond to all processes running on



the system, and there are also named entries that permit access to the current configuration of the system. Many
of these entries can be viewed.

< /lost+found >

Here, Linux keeps the files that it restores after a system crash or when a partition hasn't been unmounted before
a system shutdown. This way you can recover files that would otherwise have been lost.

< What next? >

If you're completely new to Linux, you might want to learn some commands for moving around in the file system,
viewing text files, or manipulating the files. In that case | suggest you take a look at the set of tuXfiles in the
Introduction to the Linux command line section. But first, read the next article!

Tips and Tricks

Speed up OpenOffice
Start Open Office and click on Tools > Options. This should open the configuration. Click on Memory in the left
menu and change the following settings:

* Number of Steps: 30

* Use for Open Office: 128
* Memory per Object: 20

* Number of Objects: 20

Click on Java in the left menu afterwards and uncheck "Use a Java Runtime Environment". Click OK and restart
Open Office to see how fast it is now.



Linux Command Line Tutorial
Texas A&M Statistical Dept.

Typographical conventions

In what follows, we shall use the following typographical conventions:

Characters written in bold typewriter font are commands to be typed into the computer as they stand.
Characters written in i talic typewriter fontindicate non-specific file or directory names.

Words inserted within square brackets [Ctrl] indicate keys to be pressed.

So, for example,

$ 1ls anydirectory [Enter]

means "at the shell prompt $, type Is followed by the name of some file or directory, then press the key marked
Enter"

Don't forget to press the [Enter] key: commands are not sent to the computer until this is done.

Note: Linux is case-sensitive, so LS is not the same as Is.

The same applies to filenames, so myfile.txt, MyFile.txt and MYFILE.TXT are three separate files. Beware if
copying files to a PC, since DOS and Windows do not make this distinction.

Linux Command Line Introduction

This session concerns GNU/Linux, which is a common operating system. By operating system, we mean the suite
of programs which make the computer work.

KDE (running on X Windows) provides a graphical interface between the user and Linux. However, knowledge of
the Linux Command Line is required for operations which are not covered by a graphical program, or for when
there is no graphics system, for example, in an ssh session.

The GNU/Linux operating system

The GNU/Linux operating system is made up of three parts; the kernel (Linux), the shell (bash or tcsh, typically)
and the programs.

The kernel

Linux is the kernel (or core) of the GNU/Linux operating system. It is the hub for all operations, it allocates time
and memory to programs and handles the filestore and communications in response to system calls.

As an illustration of the way that the shell and the kernel work together, suppose a user types rm myfile (which has



the effect of removing the file myfile). The shell searches the filestore for the file containing the program rm, and
then requests the kernel, through system calls, to execute the program rm on myfile. When the process rm myfile
has finished running, the shell then returns its prompt $ to the user, indicating that it is waiting for further
commands.

The Shell

The shell acts as an interface between the user and the kernel. This tutorial should apply to most shells you may
run. When a user logs in, the login program checks the username and password, and then starts another program
called the shell. The shell is a command line interpreter (CLI). It interprets the commands the user types in and
arranges for them to be carried out. The commands are themselves programs: when they terminate, the shell
gives the user another prompt (Jusername@]localhost ~]$) on PCLinuxOS.

The adept user can customize his/her own shell, and users can use different shells on the same machine. Bash is
usually the default shell in GNU/Linux operating systems, but you might be running the tcsh shell.

Shells such as the tcsh and bash have certain features to help the user inputting commands.

Filename Completion - By typing part of the name of a command, filename or directory and pressing the [Tab] key,
the shell will complete the rest of the name automatically. If the shell finds more than one name beginning with
those letters you have typed, it will beep, prompting you to type a few more letters before pressing the tab key
again.

History - The shell keeps a list of the commands you have typed in. If you need to repeat a command, use the
cursor keys ( up and down arrows ) to scroll up and down the list or, type history for a list of previous commands.
Files and processes

Everything in Linux is either a file, or a process.

A process is an executing program identified by a unique PID (process identifier).

Afile is a collection of data. They are created by users using text editors, running compilers, etc.

Examples of files:

a document (report, essay etc.)

the text of a program written in some high-level programming language

instructions comprehensible directly to the machine and incomprehensible to a casual user, for example, a
collection of binary digits (an executable or binary file)

a directory, containing information about its contents, which may be a mixture of other directories (subdirectories)
and ordinary files.

The Directory Structure

All the files are grouped together in the directory structure. The file-system is arranged in a hierarchical structure,
like an inverted tree. The top of the hierarchy is traditionally called root.

In the diagram above, we see that the directory



eeb51ab contains the subdirectory unixstuff and afile proj. txt.

Starting an shell
To start a shell, click on the Konsole terminal icon on your desktop or panel, or from the Start menu:

Start -> System -> Terminals
A konsole window will appear with a shell prompt, waiting for you to start entering commands like the one below:
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Is (list)

When you first login, your current working directory is your home directory. Your home directory has the same
name as your user-name, for example, yourname, and it is where your personal files and subdirectories are saved.
To find out what is in your home directory, type

S 1s

The 1s command lists the contents of your current working directory.

There may be no files visible in your home directory, in which case, the shell prompt will be returned. Alternatively,
there may already be some files inserted by the System Administrator when your account was created.

Is does not, in fact, cause all the files in your home directory to be listed, but only those ones whose name does
not begin with a dot (.) Files beginning with a dot (.) are known as hidden files and usually contain important
program configuration information. They are hidden because you should not change until you are more familiar
with Linux. Even then, make a backup first!

To list all files in your home directory including those whose names begin with a dot, type:

$ 1s -a

1s is an example of a command which can take options: -a is an example of an option. The options change the
behavior of the command. There are online manual pages that tell you which options a particular command can
take, and how each option modifies the behavior of the command. (See later in this tutorial)

Making Directories

mkdir (make directory)

We will now make a subdirectory in your home directory to hold the files you will be creating and using in the
course of this tutorial. To make a subdirectory called unixstuff in your current working directory type

$ mkdir unixstuff

To see the directory you have just created, type

$ 1ls

Changing to a different directory

cd (change directory)

The command cd directory means change the current working directory to 'directory'. The current working
directory may be thought of as the directory you are in, i.e. your current position in the file-system tree.

To change to the directory you have just made, type

$ ed unixstuff

Type 1s to see the contents (which should be empty)

Exercise 1a



Make another directory inside the unixstuff directory called backups.

The directories . and ..

Still in the unixstuff directory, type:

$ 1s -a

As you can see, in the unixstuff directory (and in all other directories), there are two special directories called (.)
and (. .)

In Linux, (.) means the current directory, so typing:

S cd .

means stay where you are (the unixstuff directory).

NOTE: there is a space between cd and the dot

This may not seem very useful at first, but using (. ) as the name of the current directory will save a lot of typing,
as we shall see later in the tutorial.

(. .) means the parent of the current directory, so typing:

S cd ..

will take you one directory up the hierarchy (back to your home directory). Try it now.

Note: typing ed with no argument always returns you to your home directory. This is very useful if you are lost in
the file system.

Pathnames

pwd (print working directory)

Pathnames enable you to work out where you are in relation to the whole file-system. For example, to find out the
absolute pathname of your home-directory, type cd to get back to your home-directory and then type:

$ pwd

The full pathname will look something like this:

/home/yourname

which means that yourname (your home directory) is in the directory home.

Exercise 1b
Use the commands 1s, pwd and cd to explore the file system.
(Remember, if you get lost, type ed by itself to return to your home-directory)

More about home directories and pathnames
Understanding pathnames

First type cd to get back to your home-directory, then type:
$ 1ls unixstuff



to list the contents of your unixstuff directory.

Now type:

$ 1ls backups

You will get a message like this:

backups: No such file or directory

The reason is, backups is not in your current working directory. To use a command on a file (or directory) not in
the current working directory (the directory you are currently in), you must either ed to the correct directory, or
specify its full pathname. To list the contents of your backups directory, you must type:

$ ls unixstuff/backups

~ (your home directory)

Home directories can also be referred to by the tilde ~ character. It can be used to specify paths starting at your
home directory. So typing:

$ 1s ~/unixstuff

will list the contents of your unixstuff directory, no matter where you currently are in the file system.

What do you think
S 1s ~
would list?

What do you think

$ 1s ~/..
would list?
Summary
1s list files and directories
ls -a list all files and directories
mkdir make a directory
cddirectory change to named directory
cd change to home-directory
cd ~ change to home-directory
cd .. change to parent directory

pwd display the path of the current directory



Copying Files

cp (copy) _ o _
cp filel fileZ2isthe command which makes a copy of filel inthe current working directory and calls it
filel.

Grab a copy of the file science. txt and save it to your home directory.

What we are going to do now is take a file stored in your home directory and use the cp command to copy it to
your unixstuff directory.

At the shell prompt, type the following to make sure you are at your home directory:

$ cd

Now type:

$ cpscience.txt unixstuff

On the other hand, you could have started in the unixstuff directory and typed:

$ cp ../science. txt

Don't forget the dot (.) at the end. Remember, in Linux, the dot means the current directory. The above command
means copy the file science. txt (which is located one directory above the current directory) to the current
directory, keeping the name the same.

Exercise 2a
Create a backup of your science. txt file by copying it to a file called science.bak.

Moving files

mv (move)

mv filel file2 moves (orrenames) filelto file?.

To move a file from one place to another, use the mv command. This has the effect of moving rather than copying
the file, so you end up with only one file rather than two.

It can also be used to rename a file, by moving the file to the same directory, but giving it a different name.

We are now going to move the file science.bak to your backup directory.

First, change directories to your unixstuff directory (can you remember how?). Then, inside the unixstuff
directory, type:

$ mv science.bak backups

Type 1s and 1s backups to see if it has worked.

Removing files and directories

rm (remove), rmdir (remove directory)

To delete (remove) a file, use the rm command. As an example, we are going to create a copy of the
science. txt file, then delete it.



Inside your unixstuff directory, type:

$ cp science.txt tempfile.txt

$ 1ls #to check if it has created the file

$ rm tempfile.txt

$ 1s #to check if it has deleted the file

You can use the rmdir command to remove a directory (make sure it is empty first). Try to remove the backups
directory. You will not be able to since Linux will not typically let you remove a non-empty directory. (There is,
however, an option (-r) to rm to remove a directory.

The pound sign # is the line comment character in the shell. It and everything after it are ignored by the shell.

Exercise 2b
Create a directory called tempstuff using mkdir, then remove it using the rmdir command.

Displaying the contents of a file on the screen

clear (clear screen)

Before you start the next section, you may like to clear the terminal window of the previous commands so the
output of the following commands can be clearly understood.

At the prompt, type:

S clear

This will clear all text and leave you with the $ prompt at the top of the window.

cat (concatenate)

The command cat can be used to display the contents of a file on the screen. Type:

S cat science. txt

As you can see, the file is longer than the size of the window, so it scrolls past making it unreadable.

less

The command less writes the contents of a file onto the screen a page at a time. Type:

$ less science.txt

Press the [space-bar] if you want to see another page, type [q] if you want to quit reading. As you can see, less
is used in preference to cat for long files.

head

The head command writes the first ten lines of a file to the screen.
First clear the screen, then type:

$ head science. txt



Then type:
$ head -5 science. txt
What difference did the -5 do to the head command?

tail

The tail command writes the last ten lines of a file to the screen.
Clear the screen and type

$ tail science. txt

How can you view the last 15 lines of the file?

Searching the contents of a file

Simple searching using less

Using less, you can search though a text file for a keyword (pattern). For example, to search through
science. txt for the word 'science’, type:

$ less science.txt

then, still in 1less (i.e. don't press [q] to quit), type a forward slash [/] followed by the word to search.
/science

As you can see, less finds and highlights the keyword. Type [n] to search for the next occurrence of the word.

grep (don't ask why it is called grep)

grep is one of many standard Linux utilities. It searches files for specified words or patterns. First clear the
screen, then type:

$ grep science science.txt

As you can see, grep has printed out each line containing the word science.

Or has it??7?7?

Try typing

$ grep Science science.txt

The grep command is case sensitive; it distinguishes between Science and science.

To ignore upper/lower case distinctions, use the -i option, i.e. type:

$ grep -i science science.txt

To search for a phrase or pattern, you must enclose it in single quotes (the apostrophe symbol). For example to
search for spinning top, type:

$ grep -i 'spinning top' science.txt

Some of the other options of grep are:

-v display those lines that do NOT match

-n precede each matching line with the line number

-c print only the total count of matched lines



Try some of them and see the different results. Don't forget, you can use more than one option at a time, for
example, the number of lines without the words science or Scienceis
$ grep -ivec science science.txt

wc (word count)

A handy little utility is the we command, short for word count. To do a word counton science. txt, type
$ we -w science.txt

To find out how many lines the file has, type

$ we -1 science.txt

Summary
cp filel file2 copy filelandcallitfile2
mv filel file2 move or rename filelto file2
rm file remove a file
rmdir directory remove a directory
cat file display a file
less file display a file one page at a time
head file display the first few lines of a file
tail file display the last few lines of a file
grep 'keyword' file search a file for keywords
wc file count number of lines/words/characters in a
file

Other useful Linux commands

quota

All students are allocated a certain amount of disk space on the file system for their personal files. To check your
current quota and how much of it you have used, type:

$ quota -v



df

The df command reports on the space left on the file system. For example, to find out how much space is left on
the fileserver, type:

$ df .

du

The du command outputs the number of kilobytes used by each subdirectory. Useful if you have gone over quota
and you want to find out which directory has the most files. In your home-directory, type:

$ du

gzip

This reduces the size of a file, thus freeing valuable disk space. For example, to zip science. txt, type:
$ gzip science.txt

This will zip the file and place it in a file called science. txt.gz

To see the change in size, type 1s -1 again.

To unzip the file, use the gunzip command.

$ gunzip science.txt.gz

file

file classifies the named files according to the type of data they contain, for example ascii (text), pictures,
compressed data, etc.. To report on all files in your home directory, type:

$ file *

history

The shell keeps an ordered list of all the commands that you have entered. Each command is given a number
according to the order it was entered.

$ history # (show command history list)

You can use the exclamation character (!) to recall commands easily.

$ ! #recall last command

$ -3 # recall third most recent command

$ !grep # recall last command starting with grep

You can increase the size of the history buffer by typing:

$ set history=100

So ends our foray into the command line interface (cli) of Linux. Hopefully we can put together some more short



command line howtos in the future and continue to show you where the true power of Linux is. Any readers who
would like to take on this opportunity, please feel free to contact me at papawoob@pclosmag.com.

Tips and Tricks
Make Linux Run Faster

The first thing we need to do is open our file manager in Super User Mode.

Main menu -> System -> File Tools -> File Manager — Super User Mode

Enter your Root password when prompted and then navigate to /etc/sysctl.conf and double click on it. This will
open it up in the Kwrite editor. Scroll to the bottom of this file and add these two lines below the last line which
should read kernel.sysrq=1

vm.swappiness=1
vm.vfs_cache_pressure=50

so that it looks like this:
kernel.sysrq=1
vm.swappiness=1

vm.vfs_cache_pressure=50

Now we need to save the file and close everything. As you begin using your computer again for your everyday
needs you should notice that most apps are a bit snappier.

This tip was gleaned from an interesting link found on the forums. | would recommend that you read this article in
it's entirety before proceeding with this tip. To see the original article, use this link:

http://rudd-o.com/archives/2007/10/02/tales-from-responsivenessland-why-linux-feels-slow-and-how-to-fix-that/



KDE User's Guide - Chapter 10
Using the OpenOffice Suite

Introduction

OpenOffice.org (O00) is a complete office suite, featuring a word processor (Writer), a spreadsheet application
(Calc), and presentation software (Impress). Besides these fundamental office applications OOo also includes a
vector drawing tool (Draw), allows database access, allows the publishing of documents in the Portable Document
Format (PDF) and presentations in the Flash (SWF) format!

The OO0 package is almost completely inter-operable with the Microsoft Office suite.

Getting around the package
As a first stop for information, it is important to know how the Help system works. To get help:

Help -> OpenOffice.org Help
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The search function is very useful, and pay attention to the Navigation Pane on the top left side of the window
(where you can get help for the individual components in OpenOffice.org).

Setting up OpenOffice.org preferences so that it works the way you want it to is significant. The entire controls for
this are available at:

Tools -> Options
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Fig. OO Options Window

Here you can setup settings like the default measurement units, font substitution, language types and many more
options. Saving a document automatically is not setup by default, so turning this feature on might be helpful: you
find it at the Load/Save option, under the General sub-section.

There are two important toolbars to know:

Main toolbar — this is typically located right below the menus, and contains items like new document, save a
document, exporting to PDF, copying & pasting, as well as access to the Navigator, Stylist, and Gallery.

Object toolbar — this is right below the main toolbar, and has access to font control, and other attributes of objects.



Writer

This is a powerful tool for creating professional documents, reports, newsletters and so on. It is a word processor
that allows easy integration of charts and pictures, as well as other OpenOffice.org-compatible documents. It can
create everything from a simple letter to books, with professional layouts, and the use of styles.

Start it from the Main Menu by,

Main Menu -> Office -> Word Processors -> OpenOffice.org Writer
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You are now presented with the word processing portion of OpenOffice.org and the interface is similar to other

word processing tools available. Rather than providing guidance throughout the entire package, we will just
concentrate on a few tasks at hand.



Common Functions

Functions of the word processor can be controlled via the toolbars located at the top of the screen. On the first
row, file actions like opening and saving files can be performed, while on the second row, changing the font, size,
and style (bold, underline, or italics) are located there.

They can also be controlled by the menus that are common through packages:
File -> New -> Text Document - creates a new empty, untitled document for you to work on.
File -> Open - opens the selected file.

File -> Close - closes the document you are working on. If changes have been made since your last save, you will
be prompted to save or discard those changes.

File -> Save - saves the document you are currently working on.

File -> Save As... - saves an updated version of a document in a different location, with a different name, from the
previously saved version.

Common Operations

For operations while writing, it is common to want to select a lot of text, copy it, maybe cut it from its current
location and paste it elsewhere, or even undo an action. All this is possible with the office suite, and such options
are available at the Edit menu. A few common options are:
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Fig. Common Operations

To copy text: select the text with the mouse, then select Edit -> Copy. Now the selected text is kept in memory for
use elsewhere.

To paste text: find the spot where the text needs to be placed, place the cursor there, and then select Edit -> Paste.

To cut text: this means that the selected text will be removed from the current location and kept in memory, to be
placed elsewhere. Doing this is exactly like how a copy should be performed, except select Edit -> Cut instead.

To undo an action: Select Edit -> Undo. It will display the command that it is undoing at the moment.

By browsing the menu, there are also keyboard shortcuts located next to it. Once more proficient use of the
package occurs, it is much quicker to use keyboard shortcuts like Control+C for Copy, and so on.

Formatting



Formatting text is as important as writing the text, and Writer provides many formatting options, including the
Stylist. Individually, you can also format the character (current selected item, or even a whole word), the

| | Normal | |Bitstream Vera Serif /] (12 ] [E A & [_ : EHRER - e E- e I
Fig. Part of the Formatting toolbar (Writer)

paragraph, or even the page.
Some of the quick format options include bold, italics and underline. These options are available at the toolbar at
the top of the screen.

Text alignment plays a large role in controlling how portions of the document will look. For example, an address
field at the top of your letter will have such details right-aligned, while the body and rest of the base text will be left-
aligned. This is all controlled by the four-icons that are located next to the bold/italics/underline icons, providing
such options as: right-align, centre-align, left-align and justified. When text is justified, it looks exactly like what
you're reading now! (a more professional end-to-end stretch of the text.)

Let's switch to the end of the toolbar, and notice that the options there including providing a paragraph background
— which is good for highlighting a paragraph or several paragraphs of text, in colours that you choose. You can
also highlight text (like you would with a highlighter and paper) and change the font colours all with the icons there.

Aligning text by indenting it is also another feature available as part of the object toolbar. Left/right alignment of
text is provided, and if text is already entered and you want to left-align it, selection of text (or having the cursor at
the paragraph) must happen first, before text is indented.

Those were just quick controls. To get full control, using the Format menu is ideal. Controls are more varied here.
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Fig. Format Menu

Styles

Consistency throughout a document is important. It was earlier said that writing books using OpenOffice.org is
possible. So there must be a way to handle long and large documents in a consistent fashion, with similar fonts
for headings, sub-headings, text, and other attributes within a document.

OpenOffice.org includes a powerful feature known as styles, and this is accessed via the Stylist (you can access
this by hitting the F11 key, or clicking its icon on the main toolbar). Notice the floating window, which is most likely
active at the "Default" style. By right-clicking on the style, there are options to modify the style, or create new
custom ones.

By going to the modify option, the style can be customized via many varying attributes including spacing,
alignment, font, emphasis, colour and many more. Once suitable styles have been pre-defined in the document,
they can be used on existing text just by selection, and double-clicking on the style name.

Just a little bit more...
Now that the gist of the Writer package has been covered, there's just a little more to know.



Writer has a built-in spell checker. This can be accessed via:
Tools -> Spellcheck

The option to auto-spellcheck means that while typing, Writer will dynamically check your spelling, and if it detects
an error, it will output a red-line at the bottom of the misspelled word. Keep in mind that the spell checking is
based on the current language that is in use. This can be changed via:

Tools -> Options -> Language Settings -> Languages

Accessing word counts in the document is different from most other packages on a default install of
OpenOffice.org (this can differ with several Linux distributions' offerings):

File -> Properties -> Statistics

It is under the Statistics tab that the word counts and other relevant document counts are based. On certain
vendor modified distributions of OpenOffice.org, going to the Tools -> Word Count menu will allow the Statistics
dialogue box to be displayed automatically.

The AutoCorrect (Tools -> AutoCorrect) options have replacement tables (so that CDs really are valid, and will not
be changed to Cd, for instance). There are also word completion options (very useful, as the software starts
thinking for you) and settings to make them more user-friendly.

The Navigator is a yet another useful tool (get this via hitting the F5 key or clicking its icon on the main toolbar),
especially when dealing with larger documents. It supports jumping to bookmarks, notes, any particular object,
and even creates a table-of-contents on the fly, based on the styles that are being used.

Calc
This is the spreadsheet component of the OpenOffice.org package and contains many useful features, including
an array of functions and plenty of charting options. It is fully inter-operable with Microsoft Excel, though the



function separators differ in the two packages.
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Fig. OpenOffice.org Calc

To start this, it is available via

Main Menu -> Office -> Spreadsheets ->OpenOffice.org Calc

or if you already have an existing window of OpenOffice.org open,

File -> New -> Spreadsheet.

Spreadsheets contain many rows and columns, and each row and column combination is called a cell (like A1,
B4, and so on). Upon inputting text into a cell, you might realize that the text is wider than the cell allows for — this

can be re-sized via right-clicking the cell, and selecting the Format Cells option. There under the Alignment tab,
selecting Line Break is what is required.

Formatting
Like other parts of OpenOffice.org, Calc also comes with the Stylist. But let's get around to understanding the



various differing formatting options available in this component of the package.

If there is some information that you have already created and the area should be formatted, one particular quick
and easy option is to use the AutoFormat function available in Calc. This is done after selecting the area then:

Format -> AutoFormat

These are pre-defined styles that are available in Calc, and if you have created your own particular style, you can
add them into your new AutoFormat.

In the object toolbar, there is an option to set the font colour within the cell. There are also options to
increase/decrease the indents within a cell, and in the image below, controls for enabling:

Currency
Percentage
Add/Remove significant decimal places

- NaENR X L

Fig. Part of the Object toolbar (Calc)

These are quick controls, and accessing them is as simple as clicking the icons that represent them, and
automatically the cell will be formatted as stated. Not only can Borders be set easily, and cell backgrounds too, but
the alignment of text within a cell can also be set. This can be either as a top aligned, center aligned, or bottom
aligned.

Now that most of the formatting options are known, it is easy to apply Styles to the spreadsheet. Bring up the
Stylist by hitting the F11 key, and you'll notice that cell styles (that control all elements, including formatting) and
page styles can be set (the latter controlling margins, headers/footers, and borders).



Spreadsheet basics

There are a few points to note when using a spreadsheet. One of them is that calculations are performed in a left-
to-right format, with algebraic ordering rules. This means it deals with brackets ("()") first, then division ("/"),
multiplication ("*"), addition ("+") and finally subtraction ("-").

When applying calculations, keep in mind the range of included cells. When using a function like =SUM() and
using the argument =SUM(A1:A4), it means it looks for the sum of the cells A1, A2, A3, and A4. These operations
can also be performed on non-consecutive cells, so, =SUM(A1;A4;A7) just executes the sum of cells A1, A4 and
A7.

If you have used Excel before, it would be relatively common to use a comma (",") as a separator character
between the parameters, however, with OpenOffice.org Calc, the separator character is a semi-colon (";"). So for
the function to validate correctly, an expression such as =IF(B3>0;A1-A2;A1+A2) is correct (as opposed to
replacing the ";" with ",").

Building functions

To perform calculations, spreadsheet makes use of functions. Common functions include =SUM() for summation,
=AVERAGE() for the average value of cells, and so on. As an aid to the novice user, OpenOffice.org provides a
Function AutoPilot. This is a wizard to help build formulas, and find problems with existing expressions.
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Fig. Function AutoPilot Button

Located next to the universal sum function, is the Function AutoPilot. If you click on it, a pop-up dialogue appears.

In the Functions tab, you can filter viewable/accessible functions via category, and the option to choose a function
is shown. Use your mouse to choose a function that you plan on using.

Once the correct function is selected, and the action that it performs is agreeable (it is displayed on the right of the
dialogue), select Next to move on.



Now you are allowed to input numbers. Assuming the AVERAGE function was chosen, in the number 1 field (for
example), there are options to either enter a function or select a range of cells.

Use select a range of cells and now a different dialogue pops up and you can use the mouse cursor to select a
range of cells. Click on OK, and you're done.

That is a very easy way to build a formula, which requires no prerequisite knowledge about what formulas exist in
Calc.

Sorting
A big part of dealing with spreadsheets involves a lot of sorting and filtering of data. To sort a dataset, selecting
the active cells, then clicking

Data -> Sort

This will produce a pop-up dialogue that has options for sorting the data based on the columns present, as well as
if the data should be ascending or descending.

Charting

Converting data into information is a process usually accomplished well by creating graphs and charts. It is a lot
easier to infer based on visual graphics, rather than lots of numbers. Calc provides a charting wizard that will
allow this to be automated rather easily, with a lot of predefined settings.

Select the cells that are to be charted, and then go to Insert -> Chart.
The range is pre-selected, and certain options are provided (like where the resulting chart is); just leaving the pre-
selected options will be good for the exercise. Click Next.

A type of chart is to be chosen. Common charts include pie chart, line graphs, or even bar graphs, it all depends
on the information being represented.
Select the defaults, and create a chart. (You should now see a bar chart created).



Now that a chart has been created, it is not static in the sense that it cannot be edited, you can control each and
every aspect of how the chart looks. Double-click the chart, and you will now go into edit mode. Notice the toolbar
by the left-hand side of your screen has changed? This is in direct response to it being in edit mode, and a lot of
properties can be changed here.

There are plenty more features, like data filtering, scenario creation, and goal seek, which once you get more
advanced with spreadsheet know-how, you will end up making use of.

Impress
No office suite is complete without a presentation piece, and OpenOffice.org shows its colours with Impress, the
presentation piece of the suite. To start it, it is available at

Main Menu -> Office -> Presentations ->OpenOffice.org Impress

or if you already have an OpenOffice.org window open, its available at
File -> New -> Presentation.
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Fig. OpenOffice.org Impress
Unlike other components of OpenOffice.org, when you start Impress, you are presented with a Presentation
Wizard to start creating your presentation. This gives you options to start a presentation with an empty template,
or even with one of the pre-defined templates. A preview dialogue is available, and once all options are selected
(and Next is clicked, to move on), you get a basic presentation.
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Fig. ImpressWizard for a new presentation
After choosing your background, click on Create and you will see the Presentation Main Page as seen below:
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FIg. Presentation Main Page
Template Management
If a big portion of time is going to be spent giving presentations, its very professional to have the presentation look
like each other, in the form of a template (same logo position, copyright notices, etc...). Once a template is created
(or downloaded from the Internet), you manage templates via the:



File -> Template -> Organize

Slide Design
A quick way to get slides done is via the Presentation buttons located at the top right of the window:

H @ Slide '_] Slide Design El Siide Show

Fig. Slide Buttons
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This provides a pop-up menu option that allows you to insert slides, or even modify the slide layout of the current
slide.

Views

There are several views in Impress, and some have over-lapping names, but with different functionality. At the top
of the center screen, you'll notice five buttons that look like what you see below.

Normal| outline | Notes| Handout| Slide Sorter |
Fig. View Buttons

The five options for workspace views are:

Normal view — default, for slide design.

Outline view — overlook of the presentation.

Notes view — add speaker notes.

Handout view — how handouts get printed.

Slide Sorter view — birds eye view to add, change, switch slides around.

All the views can also be accessed via: View

Master Views are supported and to access this view, go to: View -> Master and then choose the one you want.
You can have master views of all workspace views (i.e. a master view of the slide itself, notes, and handouts). The



Layer view allows layering of slides (adding and removing), and layers can be non-printing or non-displayed on
screen, but printing only.

Jazzing up the presentation
Objects, like video, Java applets, music, and even other graphics can be added (embedded) to a presentation
very easily. To perform this, the following menu is useful:

Insert -> Object

Keep in mind that OpenOffice.org will only play content provided all relevant plug-ins are installed. For sound
playback, it assumes an already configured sound-card, otherwise it will not work.

Effects are another supported feature in Impress and consist of things like slide transitions, mouse-driven bullet-
points, and even drawing animations. To get to the effects pop-up, click on Slide Show on the Navigation Toolbar.
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Fig. Slide Show Options
Performing slide transitions are also accessed via the effects menu. However, to create animations, the menu is:




Slide Show -> Custom Animation...

Here, simple animations can be created, like making your text move from side to side and fade in and out. This is
done simply by clicking on Custom Animation..., highlight the part of your text that you would like to animate and
then click "Add.." from the window on the right. This will create a popup window like the one seen below:

Custom Animation

Entrance | Emphasis | Exit| Motion Paths |

Basic
Appear
Box
Checkerboard
Circle
Diagonal Sguares
Diamond
Dissolve In
Flash Once
Fly In
Fly in Slow
Peek In
Plus
Random Bars
Random Effects
split
Venehan Blinds
Wedge
Whee/

Speed Medium
™ Automatic preview

oK | Cancerl Help |

Fig. Custom Animations Window
Now you simply choose an option from each of the 4 tabs in the window above and then click on "Play" from the
window on the right to see the effect you created.

Conclusion

OpenOffice.org has the ability to be a very useful software package. It includes very powerful, free alternatives to
satisfy average office suite requirements. As this is only scratching the surface, there are plenty more resources
available out there, so please, use the available documentation to its fullest.



| am sad to say that this brings us to the end of our KDE User Guide series. By the time you read this you should
be able to download the entire guide in PDF format from our website at www.pclosmag.com.
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