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Preface

This user guide is meant as an introductory guide for a user to use a modern 
personal computer (PC) running the Linux operating system. The main aim is to 
provide a self-learning guide on how to use a modern Linux desktop system. It 
assumes that the user has no prior knowledge of Linux or PC usage.

After going through the guide the reader should be in a position to start using a 
Linux desktop for both personal and office use. In particular she should be able 
to:

access the Internet and use the WWW and Internet email
manipulate and manage files, folders and the file system
produce and print simple documents and presentation materials
advance to become a power user by further self-learning and exploring

Chapter 1 – Getting Started

I've updated this guide to reflect the desktop environment called KDE. It's more 
"Windows" like, and it seems to have a few more bells and whistles. I've taken 
the screenshots from my computer, which isn't set up exactly the same as yours, 
but it's pretty close.



In order to start using your system you will usually have to perform what is 
known as a user login. This procedure is necessary to identify yourself to the 
system. The system allows multiple users to use it concurrently and so it has to 
be able to identify a user in order to grant them the necessary privileges and 
rights to use the system and applications. Each user, upon successful login, will 
be assigned to his home directory (folder).

Some systems may have been set up so that upon power-on, a default user is 
logged in automatically. If this is so, then you will not be presented with a login 
screen or prompt as described in the section below. You may skip on to the 
section entitled "Basic Navigation using the Mouse on the Desktop". I would 
however recommend reading this section in case you ever have to log out and log 
back in.

Note:
There is a special user called root or superuser (this user is usually created 
during the system installation) which has unlimited access and rights to all the 
system files and resources. You only need to login as root if certain system level 
administrative tasks are to be carried out. Otherwise there is usually no need for 
a normal user to login as root. This is to prevent accidentally damaging the 
system by deleting or modifying important system files.

Fig. Login Screen



When you reach this screen, type in your user name and then type in your 
password and press enter. This will bring up a splash screen showing your 
desktop being loaded as seen below:

When the blue lights on the bottom finish lighting up the next thing you will see 
is your Kde desktop as seen below:



Text Based Login Prompt

To login, enter the user name followed by the ENTER key and when the 
password prompt appears, enter the password followed by the ENTER key.

Starting the Graphical Desktop

If you have logged in from the graphical login screen, the graphical desktop will 
be started automatically for you. The graphical desktop presents a Graphical 
User Interface (GUI) for the user to interact with the system and run 
applications. If you have used the text-based screen login, you will have to start 
the graphical desktop manually by entering the command startx, followed by the 
ENTER key.

Note:
The graphical desktop that we will be using throughout most of this guide is 
called the KDE Desktop. There is another desktop environment in popular use 
on Linux systems – the GNOME Desktop. There is some coverage of GNOME 



later, comparing the similarities and differences between GNOME and KDE 
although we will not be covering the GNOME desktop in detail.

For the rest of this user guide, when we refer to the graphical desktop or 
Desktop we shall be talking about the KDE Desktop unless stated otherwise.

Using the Mouse on the Desktop

Proper usage of the mouse is essential in order to have a rewarding and 
productive experience on the graphical desktop. Most Linux graphical desktops 
are designed for use with a 3-button mouse. If you are using a 2-button mouse, 
during installation, it should have been configured to emulate the middle-button 
of a 3-button mouse by pressing both buttons simultaneously.

To click on a mouse the left button is depressed. (A mouse configured for a left-
handed user will will need to have its right button depressed.) The right (or left 
button for a left-handed mouse) and middle buttons are usually used to invoke 
special or specific features of the GUI and instructions to do so will be explicitly 
given.

The term "clicking on the mouse" means that you click on the mouse once.

The term "double clicking" means that you click twice in succession on the 
mouse.

To "select" an item means clicking it once with the mouse.

The term "drag and drop" means that you will have to click on an item and while 
continuing to hold the mouse button down, drag the item to another place and on 
reaching its destination drop it by releasing the mouse button.

Exercises

Open the home / My System folder  from the Desktop.
Close the home folder window by clicking on the close window button at the top 
right-hand corner.
Right-click on the trash icon, view its properties and close it back.
Move the trash icon to another location on the desktop by using the mouse to 
drag it to the new location and releasing the mouse.

Main Components of the Desktop

There are 3 main components to a Kde desktop. They are:
The Menu System
The Panel
The Desktop Itself

The Menu System



The main menu can be accessed by clicking on the Main Menu button located at 
the extreme lower left hand corner of the desktop. It looks like this:

Clicking on this will bring up the Menu System as shown in the figure below.

Fig. The Menu System

From the Menu System you can start many of the applications installed on your 
Linux system. Note that the Menu System consists of a Main Menu panel and 
sub-menu panels. Each entry in the Menu System which has an arrow on its right 
means that it is an entry point to a sub-menu, and there can be sub-menus within 



each sub-menu. In this way applications in the Menu System can be organized 
and categorized for easy reference and access.

To access a the sub-menu associated with a menu entry, move the mouse and rest 
it on the menu entry in question and a sub-menu panel will appear.

Fig. Main Menu and Sub-menu

Clicking once on a menu entry will cause an application associated with it to be 
launched, i.e. executed.

The Panel

The long bar across the bottom of the desktop screen is called the Panel. The 
Panel contains the Main Menu icon, the application launcher icons, a notification 
area and applets.



Fig. The Panel

Installed by default are several application launcher icons on the Panel. Clicking 
on one of these will run an application. Commonly accessed applications can be 
added to the Panel and those that are less frequently used can be taken off.

The notification area holds alert icons so that the user can be alerted to critical 
messages.

Applets are small applications that run on the Panel. These usually perform 
useful and informative tasks like setting the sound level of the sound card, 
monitoring whether the system software needs an update, etc.

The Workspace Switcher

The graphical desktop can be regarded as a workspace drawing an analogy with 
the working area on a real physical tabletop. Programs are run, documents 
displayed  and files opened on the workspace. To cut down on workspace clutter 
and to enable the user to organize his/her workspace more efficiently, the 
graphical desktop environment allows the usage of multiple workspaces. Each 
workspace can be considered as a virtual desktop.

Fig. The Workspace Switcher

By default the user has 4 desktop workspace areas to work on. The workspace 
switcher represents each workspace as a small square and shows the 
applications running in each of them. To access a workspace click on the square 
with the mouse.

The Taskbar

The Taskbar applet is located next to the workspace switcher and shows the 
titles of all the running applications in a virtual desktop (a workspace).

The Desktop Space

The Desktop space refers to the rest of the screen. It contains icons which are 
graphical representations of short-cuts to application launchers, file folders, files 
and peripheral devices like floppy disks, CD-ROM drives and printers. Double-
clicking on an icon representing an application will launch or execute the 



application. Commonly used applications and/or files/folders are usually placed 
on the desktop space.

Using the Window Manager

An interactive application that is run on the graphical desktop is usually 
displayed inside a window. This window can be accessed and manipulated using 
the window manager.

Fig. An Application Window Frame

The Titlebar

When an application is started an application window opens and a frame (see 
figure above) is placed around the window of the application. The top edge of the 
frame has a title bar that contains
 the title of the application.

At the left hand corner of the title bar is the Window Menu button. Clicking on 
this button will open up the Window Menu.



You can perform operations such as minimize, (un)maximize, shade, move, resize 
and close the window from this menu. At the right edge of the title bar there are 
three buttons which allow you to minimize, (un)maximize and close the window.

To perform an operation in the Window Menu, open the menu by right clicking 
on the Window Menu button and then select the desired operation.

Manipulating the Window

Some basic instructions to manipulate the windowing system are given here. 
More details can be obtained by clicking on:

 Main Menu-> More Applications-> Documentation-> KDE Help Center.

 After the KDE Help Center opens choose KDE User Manual and scroll down to 
"Windows, How To Work Them."

Focus

In order for a window to receive input from the mouse and the keyboard it has to 
be the window "in focus". Only one window can have focus at a time. Windows 
that are not in focus have their title bars grayed-out. To focus on a window place 
the mouse on the title bar and click on it. (You can actually click anywhere within 
the window, but it is safer to click on the title bar since there is no possibility of 
accidentally clicking on some item selection or functionality of the application 
running within the window.) If the window is not visible, you can click on the 
Taskbar on the Panel at the bottom of the Desktop to bring into focus the window 
you want.

Maximize and Minimize

Maximizing a window means that the window is expanded to cover the whole 
desktop while minimizing it means that the window is taken off the desktop and 
it appears as an icon in the Taskbar on the Panel.

You can maximize a window which has focused from the Window Menu or by 
clicking on the maximize button on the title bar. You can similarly minimize the 
window. If the window does not have focus bring it into focus first by clicking on 
the Taskbar on the Panel.



Resize

You can resize a window, i.e. change its size, by placing the mouse at an edge of 
the window and then drag the window to the desired size.

Move

To move a window to another place on the desktop, place the mouse on the title 
bar and drag the window to the desired location.

Close

You can close a window which has focused from the Window Menu or by clicking 
on the close window button on the title bar.  If the window does not have focus 
bring it into focus first by clicking on the Taskbar on the Panel.

Note: Closing the window will terminate your application.

Move to Workspaces

The Window Menu can be used to move the application currently opened to 
another workspace or to all the workspaces.

Exercises

Open your home folder from the Desktop. Perform the following operations on 
the opened window:
maximize it
minimize it
resize it
move it to another area of the desktop
place it on workspace 3
close it

Ending the Session

To end this chapter, you can exit your session on the desktop by performing what 
is known as a logout. If you do not want to use the system any more, you can 
turn it off by performing a system shutdown.

Logout

When you have finished working on the system, you will need to logout. Logging 
out will inform the system that you are no longer using the system's resources. 
All the files opened and programs run by you will be closed and/or stopped 



unless you have specifically informed the system to keep them open or running 
for you.

To logout, at the Main Menu select: 

Main Menu -> Log Out

and at the dialog window select End Current Session and click OK.

Shutting Down the System

When you have finished using the computer and want to power it off, you will 
have to perform a system shutdown. To shutdown, at the Main Menu, perform a 
logout. Then at the graphical login screen select the "Turn Off Computer" option. 
You will also have the option to "Restart Computer."

Note:
It is very important that a proper system shutdown is performed. You should not 
just turn off the power switch of the computer to shut it down. Failure to observe 
this may lead to system software and data corruption and failure.

Chapter 2: Using the Desktop

Basic Desktop Customization



The desktop can be customized to your preferences and tastes in a variety of 
ways. Here we will explore some basic customizations. More details can be 
obtained by clicking on:

 Main Menu-> More Applications-> Documentation-> KDE Help Center.

 After the KDE Help Center opens choose KDE User Manual and scroll down to 
"III. Kde Components."

Desktop Background

The background image displayed on the desktop can be changed by running the 
Background application. Just right-click on the desktop and select "Configure 
Desktop."

Fig. Right Click Menu

After clicking on "Configure Desktop" you will see a dialog box that looks like 
this:



Fig. Configure-KDesktop

To change the background image, click on the Background tab on the left. Next, 
click on the "Picture" image selector dialog. Choose an image from the dialog. As 
you select each image, a thumbnail (small picture) will be displayed in the 
monitor to the right of your selection.



Fig. Selecting a New Background image

If you want to choose an image from another directory, click the Browse button. 
The Browse button is located to the right of the "Picture" image selector dialog 
and looks like a file folder. When you have chosen an image, click on "Apply" and 
then click "OK."

Desktop Behavior

Our next option in the Configure-KDesktop window is "Behavior." The "General" 
tab allows you the options of whether or not you have file icons or device icons 
and if you chose to have them on your desktop, which ones you want to be seen. 
See figures below. It also allows you to setup what each of your mouse buttons 
do when they are  clicked. You can also choose whether you would like your 
Menu bar at the top of your screen and if so, what style.



Fig. Behavior Dialog

Fig. File Icons



Fig. Device Icons

Multiple Desktops

The "Multiple Desktop" tab allows you to increase or decrease the number of 
virtual desktops that are available in your Taskbar. To change the number of 
desktops, you can use either the "slider" or the up and down arrows located to 
the right of the slider. Each time the number increases (or decreases) you will 
add (or subtract) 4 more virtual desktops.



Fig. Multiple Desktops

Screen Savers

The next configuration option in the "Configure KDesktop" dialog window will let 
us setup our screen saver. Choose this option by clicking on the "Screen Saver" 
tab located on the left side of the dialog window and you will see a window that 
looks like this:



Fig. Screen Saver

The first thing you will notice will be a long list of different types of screen 
savers. If you click on the little "+" sign next to any of these it will show another 
list of that particular type of screen saver like this:



Fig. Screen Saver Types

There are far too many types to cover in this howto so you will have to 
experiment and look at them until you find one that you like. This window works 
just like the background window did. Click on a screen saver and a thumbnail 
(small picture) will be displayed in the monitor to the right of your selection.

 You will also notice a "Setup..." button and a "Test" button below the list of 
screen savers. Some screen savers require extra information so that you can 
make them work exactly as you wish, which is what you would use the "Setup..." 
button for. The "Test" button will bring up the screen saver in full screen mode so 
that you can see what it will look like when it starts.

There are two other options in this window. The first is whether or not you want 
to have the screen saver start automatically, and if so, how long after there is no 
activity. Simply use the up and down arrows to set the number of minutes.

The second option allows the screen saver to effectively "lock" your desktop. To 
unlock the screen saver you will have to enter your password into the box that 
will pop up when you try to go back to your desktop.

 There also is an "Advanced Options" button under the monitor where your 
thumbnails are displayed. It allows you to start your screen saver by moving your 
mouse into a particular corner and leaving it there. Your choices can be seen 
below:



Fig. Advanced Options

Display

The last tab in the "Configure Kdesktop" window is the "Display" tab. There are 
three tabs in this window: Size & Orientation, Monitor Gamma, and Power 
Control. We will only explore the "Size & Orientation" and "Power Control" tabs.

The only thing on this page that is of interest to this howto is the "Screen 
size" (resolution) tab. This adjusts the size of everything on your desktop 
including the icons, fonts, Taskbar, etc.... 

The Kde desktop will default this setting to the largest resolution that your 
monitor can handle. In the screenshot below you will see that mine is set to 
1280x1024. If you click on the arrow next to this setting you will see a list of 
resolutions that are available for your monitor. The smaller the number, the 
larger everything will appear. Choose one and then click "Apply." The desktop 
will go blank for a moment and then you will see your desktop in the new 
resolution with a dialog box asking whether or not you want to accept this new 



resolution. If you want to accept it then use your mouse to click on the accept 
button. (Note: Do not try this if you are running any 3D effects.)

If you would like to have this as your default resolution when you start Kde, then 
click on the box next to "Apply settings on Kde startup."

Fig. Display

Chapter 2 – Part 2

Welcome back to our continuing journey into the mysteries of the Kde Desktop 
Environment. This part is mostly about using all of the available eyecandy to 
make your desktop look and function exactly the way you want it to. So lets jump 
right in!

Desktop Themes

The desktop theme specifies the visual appearance of the panels, applets, and 
windows by combining settings for the background, colors, window style, icons, 
fonts, and screen saver. The desktop theme may also specify the appearance of 
interface items in applications. For example, the theme affects the appearance of 
buttons, scrollbars, check boxes, and so on in the applications.



The theme used by the Desktop can be changed by running the Theme manager 
from the Menu.

Menu-> System-> Configuration-> KDE-> System Administration-> Theme 
Manager

A theme selector dialog window is displayed. The screenshot below shows a 
sample of some of the themes which may be available. Note that the actual 
themes available can vary from system to system.

Fig. Theme Manager

As you can see in the Theme Manager screenshot, you will find a list of available 
themes in the upper left hand corner. To choose a theme just click on one and 
then click on the "Install New Theme" button. If the new theme does not suit 
your fancy then try another, and another, and another, until you find one that you 
like.

Now, it is possible that you do not find any of the default themes to your liking. 
Have no fear! The "Get new themes..." link in the upper right hand corner will 
transport you to http://www.kde-look.org/ where you will find literally hundreds 

http://www.kde-look.org/


of other themes. It will also be your source for just about any form of eyecandy 
that you will ever need for your Kde desktop.

Before we move on, make note of the six tabs that are located along the bottom 
of the Theme Manager window. We previously covered Backgrounds and Screen 
savers in Part 1. Clicking on either of these tabs will bring you to windows that 
you are familiar with already. The other four tabs (Fonts, Style, Icons, and 
Colors) are what we will be covering in the following paragraphs.

Default Fonts

The default fonts used to display applications and the desktop background can be 
changed by running the Fonts application from the KDE Theme Manager or by 
using the menu.

Menu-> System-> Configuration-> KDE-> Fonts

A selector dialog for the application, window title, dialog and terminal fonts are 
displayed as seen below:

Fig. Fonts Window



To change the font for each category of usage, click on the "Choose" button to 
the right of each space listing the font. This will bring up a new dialog window 
where you will be able to choose different fonts and see what they will look like 
before deciding which one you want as you can see below:

Fig. Selecting New Fonts

As you make your choices of Font, Font style, and size, You will see the effects of 
each of your choices in the box at the bottom of the window. Once you have 
found the right combination, click on the "OK" button.

Style

The Style tool is used to customize the appearance of menus, menubars, and 
toolbars. Again this can be run from the KDE Theme Manager or by using the 
menu.

Menu-> System-> Configuration-> KDE-> Style



Fig. Style Dialog Window

As you can see in the screenshot above, the Style window gives you three tabs, 
Style, Effects, and Toolbar. The greatest effect created by these three tabs will be 
with the "Widget Style" part of this window. Experiment on each of the settings 
to find the ones you prefer.

Icons

The Icon theme window offers you many choices as you can see below:



Fig. Icon Theme Window

Go ahead and choose an icon theme by clicking on any of the listed themes. Pay 
attention to the three icons located above your theme list. As you click on each 
theme you will notice these icons change to show you how they will look on your 
desktop. When you find one that you like, click on the "Install New Theme" 
button.

The "Advanced" tab offers you the ability to set effects for your Default, Active, 
and Disabled icons. You can also choose to animate your icons and change the 
pixel size. Now we can move onto Colors.

Colors

The Colors Dialog window gives you many choices of color themes to choose 
from.



Fig. Colors Dialog Window

As we seen with the Icon window above, you can again see the effects of your 
choices at the top of the window. When you find the one you want, click on the 
"Save Scheme..." button.

Exercises
 
Experiment with each of the following desktop preferences:

Themes
Fonts
Styles
Icons
Colors

Using the Desktop

The Desktop provides a useful metaphor for a modern office work environment. 
So on the Desktop we find that the applications that we want to run can easily be 
started or launched and the information and data that we need can easily be 
located.



Running Applications

Applications that we can run from the Desktop are to be found either from the 
Main Menu (and sub-menus therein), or as icons on the Panel and the Desktop 
itself.

To run an application from the Main Menu, open up the menu (or sub-menu) and 
click on the application listed in the menu bar.

To run an application from the Panel, click once on the icon representing the 
application.

To run an application from the Desktop itself, double-click on the icon 
representing the application.

Sometimes it is more handy to have an application as an icon on the Panel or 
Desktop where you can launch it more easily by just clicking on it, rather than in 
the Main Menu, especially if it is buried deep within several sub-menus. To 
achieve this, open the Main Menu and select the application item listed in it by 
clicking with the right mouse button. Click on the "Add Item to Main Panel" and 
a copy of the application icon will be placed on the Panel.

To make a link of the application on the Desktop, click with the right mouse 
button, and select "Add Item to Desktop" and the application icon will be placed 
on the the Desktop.

To delete an application icon from the Panel, right-click on it and select the 
"Remove <application> Button" option.

To delete an application icon from the Desktop, right-click on it and select the 
"Move to Trash" option.

The Panel

The Panel houses many useful utilities called applets. Applets are small 
applications that run on the Panel. As discussed in Chapter One, by default, the 
Taskbar and the workspace switcher applets are placed in and run on the Panel. 
Other useful applets that may be placed on the Panel include:

clock
dictionary
volume control
preferred applications

Placing an Applet on the Panel



To place an applet on the Panel, move the mouse over to an empty space on the 
Panel and right-click it. Select the item "Add Applet to Panel" and from the sub-
menu select the applet to place on the Panel. For example, to place the 
"dictionary" applet on the Panel, select:

Add Applet to Panel --> Dictionary

Fig. Add Applet

To prevent accidental removal of an applet, you can lock the Panel by right-
clicking on it and selecting "Lock Panels".

Removing an Applet from the Panel

To remove an applet, right-click on the applet icon and select the "Remove 
<application> Button" option. If the applet is locked, you will have to unlock it 
first by right-clicking on the icon and selecting "Unlock".

Configuring the Panel
To change the properties of the Panel, right-click on the Panel and select 
"Configure Panel".



Fig. Configure Panel

From the Arrangement properties tab you can change the position, length, and 
size of the Panel.

From the Hiding properties tab, you can hide and (un)hide the Panel, as well as 
change how other windows interact with it.

From the Menus properties tab, you can change how the Main Menu displays its 
entries.

From the Appearance properties tab, you can change the color of the Panel as 
well as its visual appearance.

From the Taskbar properties tab, you can change how the Taskbar displays 
running programs in the Panel.

Launchers

Launchers allow the user a quick way to access specific resources on the system. 
For example if a user needs to access a specific file in one of the folders often, 
he/she can create a launcher to run an application to open the file and this 



launcher can be placed on the Desktop. In this way the resource (the file) can be 
accessed very quickly by just double-clicking on it.

To create a launcher on the Desktop, right-click on an empty area on the Desktop 
and select the item "Create New." From the sub-menu, select "Link to 
Application". Enter the Name and the Command to run (in the box seen below) 
and if you want, you can select an icon for it by clicking on the icon button.

You can find most of the commands you need by clicking on the "Browse..." 
button, use the "up" arrow to move up in the file structure to "/" and double-click 
on "/usr." Once that window opens you can double-click on either "/bin" or 
"/share" and choose the necessary command in most cases.

Fig. Creating a Launcher



Exercises

The Firefox web browser is a popular web browser application for Linux systems. 
Locate the Firefox application in the Main Menu and place it on the Panel as well 
as the Desktop. Launch the Firefox application from:

the Desktop
the Main Menu
the Panel

Configure the Panel so that it has the following properties:
a background color of solid blue
contains the Klipper and Storage Media (locked) applets

Create a launcher to run the text editor command "kate" on the Desktop. Use an 
appropriate icon for the text editor.

Setting the Date and Time

It is important that the date and time are set correctly in your system. This will 
make it easier to manage the system resources and files, and also aid in 
troubleshooting any problems. To set the date and time, run the Date & Time 
application tool from the Menu:

Menu-> System-> Configuration-> KDE-> System Administration-> Date & Time

Alternatively you can right-click on the clock (time) applet display on the Panel 
and choose "Adjust Date & Time".

Fig. Right Click Clock Menu

A dialog box asking for the root password will appear if you are not logged in as 
root. This is because the system date and time are important system parameters 
and so only the system administrator, or root, is allowed to do it. After entering 
the correct root password, you can change the date using the displayed calender, 
and the time in the boxes provided. Select the Time Zone tab and check to see 
that the timezone selected is correct. If not, correct it by selecting the 



appropriate timezone region. Usually the system uses the local time, so do not 
select the "Set date and time automatically" check-box.

Fig. Setting the Date and Time

Click on the Apply button after all is done to enable the new date and time. You 
can check for the new date and time by resting your mouse over the clock (time) 
applet display on the Panel at the bottom of the screen. If the time is correct, 
click on the OK button.

You can also change the appearance of your clock by right-clicking on the clock 
(time) applet display on the Panel and choose "Type." This will give you four 
choices (Digital is the default), Plain, Analog, and Fuzzy.

Exercises

Practice setting the date and time.
Practice changing the appearance of the desktop clock

Chapter 3: Files and Folders

The File System



One of the most powerful features of a modern computer system is the ability to 
store data in a form which can be easily retrieved and transported or copied 
across to other computer systems or media. Data created and accessed by a user 
in the computer is stored in what is called a file. This concept of an electronic file 
to store electronic data mimics the physical world usage of a file to store data 
written on paper. This mimicry is carried further by the organization of these 
electronic files into electronic folders or directories. Like a physical folder, an 
electronic folder can contain many files. A folder may also have sub-folders or 
sub-directories.

Note:
We shall be using the terms folder and directory interchangeably, unless stated 
otherwise.

Fig. The Hierarchical File System

Files and folders can be created, copied, moved (i.e. transferred) and deleted. 
The folders themselves are organized in a hierarchical manner starting at the 
root of the file system. Each user is given a home directory and upon logging in, 
the user is placed in his home directory.

Ownerships and Permissions

As the system is set up to handle multiple users concurrently, it needs to have in 
place mechanisms with which it can control the security and privacy of the file 
system. It needs to be able to control access to the file system resources for each 
individual user. In addition, it also has to be able to control access at a group 
level i.e. users who belong to the same group can be given certain privileges 
with respect to the file system operations. To be able to perform these features, 
associated with each file or folder are the categories:

owner
group
others

and the file permissions:

folder

sub-folder file

filefile



read (r)
write (w)
execute (x)

and the directory permissions:

read (r)
write (w)
access (x)

Associated with a file are the categories owner, group and others and the 
permissions which each one of these have on the file. The user id of the user who 
creates a file by default becomes the owner of the file. User ids on the system 
are assigned to one or more groups. When a user id is created on the system, a 
group which has the same name as the user id is also created and the new user 
id belongs to this group. By default this group (which has the same name as the 
file owner) is associated with the file. All of the other user ids on the system 
which are not the owner of the file or do not belong to the group associated with 
the file, are placed in the category others.

By default the owner has read and write permission for a non-executable file and 
read,write and execute permission for an executable file. The group associated 
with the file has read permission for a non-executable file and read, and execute 
rights for an executable file. The others group has read only permission for a 
non-executable file and read, and execute rights for an executable file.

The rights and ownership concepts described above apply to directories too. 
However, since a directory cannot be executed, access rights are substituted for 
execution rights. Access to a directory means that the user id with the 
appropriate permission can descend into the directory (i.e. change directory to 
it).

The File Manager application described below may be used to view and modify 
the ownership and permissions of a file or folder. Only the owner of a file/folder 
can change its permissions and only the superuser or root can change the 
ownership of a file/folder.

Viewing and Modifying the Permissions of a File or Folder

To view the owner and group of a file/folder and/or to modify its permission 
settings, right click on the file and choose Properties or select the file/folder and 
select from the menu bar at the top or:

File --> Properties

Click on the Permissions tab. The owner and group of the file/folder are 
displayed as well as the associated permissions. The "Others" tab shows the 



permissions for users who are not the owner of the file or a member of the 
owners group. A screenshot is provided below:

Fig. Ownership and Permission Properties of a File

To change the permissions, click on the arrow next to the boxes and choose the 
new permissions desired. Click on OK to apply the changes.

Note: It is recommended that you do not modify the default file/folder 
permission settings unless you know what you are doing. This is to minimize the 
risk of compromising the security of the files and folders. 

Using the File Manager

As it is possible for a user to create and store hundreds and thousands of files 
and folders, a File Manager is needed to assist the user to manage and 
manipulate these files and the file system on which it resides.

In this section, a brief description of the File Manager and how to use it is given. 
More details can be obtained by clicking on the Main Menu and then on More 
Applications, Documentation, and then KDE Help Center. After the KDE Help 
Center opens, choose KDE User Manual and scroll down to "II. The File 
Manager."



KDE User Manual --> The File Manager

To start using the File Manager (Konqueror), double-click on the home directory 
icon on the desktop or in the panel. (This should be named "Home" and look like 
this:

Fig. Home

When you click on the "Home" icon seen above the File Manager will open a 
window that looks like this:

Fig. The File Manager



By default, the File Manager window consists of a side pane and a main view 
pane. At the top of the window just under the window title bar, are the menu bar 
and the location bar.

The view pane displays the files and folders contained in the current directory 
that the user is in. These can be displayed as icons (default) or changed to 
display them as a listing of filenames.

The side pane contains an icon that represents the current file or current folder. 
The side pane also contains information about the current file or current folder. 
A hierarchical (tree) view of the file system on the computer can be obtained 
from the side pane. By navigating through this, you can access files and folders 
outside your home directory (provided of course that you have the permission to 
do so).

Fig. The Side Pane with a Tree View of Folders

Accessing Files and Programs

From the view pane of the File Manager, you can open files as well as run 
(launch) executable programs by double-clicking on the icon representing them.



Creating New Folders

To create a new folder under the folder you are currently in, move the mouse to 
the menu bar at the top (just beneath the title bar of the window) and click on 
Edit and then click on Create New. A submenu will pop out to the right, and then 
click on Folder. A new folder will appear ( as seen below ) on the view pane and 
you will have to type in the name of the new folder.

Copy Files and Folders

If you want to make a copy of a file you will have to place the copy in another 
folder as you cannot have two files with the same name, in the same folder. To 
copy a file, right click on the file in the view pane to select it. Then select "Copy 
To" from the drop menu as seen below:

Fig. Copy To

After selecting "Copy To" you will see another drop menu that lists your entire 
file system. Choose where you want the file to be copied to and select "Copy 
Here."



Fig. File System drop menu

Fig. Copy Here

Another method is to right click the file which will bring up the same drop menu 
seen above. You can also click on the file in the view pane to select it and then 
select from the menu bar at the top,

Edit --> Copy File...

This will open a dialog box where you can type in the path to the folder to where 
you want to move the file to or click on the browse folder and navigate to it, as 
seen below:

Fig. Copy File

The procedures above can be done with folders also.



To copy more than one file or folder at a time, select multiple files/folders by 
holding down the CTRL key while clicking on the files or folders. Then repeat the 
steps shown above.

Moving Files and Folders

Moving a file or folder is different from copying in that a copy of the file/folder is 
not made, i.e. only one copy of the file/folder exists, and the file/folder is 
transferred from one folder to another.

To move a file, right click on the file in the view pane to select it. Then select 
"Move To" from the drop menu as seen below:

Fig. Move To

After selecting "Move To" you will see another drop menu that lists your entire 
file system. Choose where you want the file to be copied to and select "Move 
Here."

Another way of moving a file is to drag and drop the file into the destination 
folder.

You can also click on the file in the view pane to select it and then select from the 
menu bar at the top,

Edit --> Move Files...

This will open a dialog box where you can type in the path to the folder to where 
you want to move the file to or click on the browse folder and navigate to it, as 
seen below:



The procedures above can be done with folders too.

To move more than one file or folder at a time, select multiple files/folders by 
holding down the CTRL key while clicking on the files or folders.

Renaming Files and Folders

To rename a file, right click on the file in the view pane to select it. Then select 
"Rename" from the drop menu as seen below:

Fig. Rename

and then type in the new name. You can also click on the file in the view pane to 
select it and then select from the menu bar at the top,

Edit --> Rename

The procedures above can be done with folders also.

Deleting Files and Folders



To delete a file, click on the file in the view pane to select it. Then select from the 
menu bar at the top,

Edit --> Move to Trash

You can also right click on the file and select "Move to Trash" or “Delete” from 
the drop menu.

Alternately, you can select the file and then use the DELETE key on the keyboard 
to delete the file. This has the same effect as above of moving the file to the 
Trash folder.

It is still possible to salvage a deleted file from the Trash. To do this double-click 
on the Trash icon on the desktop to open up the Trash folder. Then you can move 
the file you want to salvage to the desired folder. 
Note: if you delete the file from the Trash then it cannot be recovered anymore.

The procedures above can be done with folders also.

To delete more than one file or folder at a time, select multiple files/folders by 
holding down the CTRL key while clicking on the files or folders.

The Trash Can

The trash can icon on the desktop contains files and folders which you have 
deleted using the File Manager or an application run from the desktop. As noted 
above, it is a special folder in which it is still possible to recover the deleted 
items to another folder so as to "undelete" them. However, over time, the trash 
folder will be filled up, as many files and folders get deleted through usage. So it 
is a good idea to periodically empty or delete the items found in the trash.

Fig. Empty Trash Can

Fig. Full Trash Can

To empty the trash, right-click on the trash icon and select "Empty Trash Bin." 
Otherwise, you can open the trash by double-clicking on it and then select:

Edit -> Selection -> Select All



and then:

Edit -> Delete

Using A Text Editor

Very often it is necessary to use the computer to input some text or to modify the 
data in a text file. While a full-fledged word processor like OpenOffice.org's 
Writer may be used, it can be an overkill since the sophisticated features and 
formatting available with a word processor are not needed in many cases. A text 
editor can be used instead. The PCLinuxOS system comes installed with many 
text editors. In this section we shall be looking at how to use a text editor which 
comes with the KDE Desktop - KWrite.

Note:
A text file here refers to a file which contains pure text printing characters only. 
Some types of files e.g. those created by a word processor, while appearing to be 
text-only actually contain other non-printing characters and hence are not pure-
text files.

Starting KWrite

KWrite may be started from the Main Menu,

Main Menu --> More Applications --> Editors --> KWrite



Fig. The KWrite Text Editor

After KWrite has started, you can immediately type in text into the main edit 
window. The mouse is also used extensively in KWrite, to move around the 
document as well as to perform editing functions.

Inputing Text

Text can be entered by simply typing into the main KWrite window. By default, 
the text will wrap to the next line when it reaches the border of the editing 
window.

Marking Text

The mouse may be used to mark (highlight) a block of text by clicking on the 
beginning of the block and dragging the mouse to the end of the block before 
releasing it.

Deleting Text



Text can be deleted one character at a time by moving the mouse to the 
character in question and using the DELETE or BACKSPACE keys in the normal 
fashion.

If there is a lot of text to be deleted, a more efficient way to delete text is to mark 
it first and then press the DELETE key on the keyboard. 

Copy, Cut, and Paste

Text can be edited by marking it first and then selecting Cut, or Copy from the 
buttons at the top. "Cutting" will result in the marked text being copied into a 
storage buffer and then deleted from the editing window, while "Copying" will 
result in just a copy of the text being copied into the storage buffer without the 
deletion of the original text. The text cut/copied in this way can then be pasted 
into another part of the document by moving the mouse to the desired location 
and selecting the Paste button at the top.

Another way of invoking these functions is to click on the Edit option on the top 
menu bar and selecting the desired function, e.g.

Edit --> Cut
Edit --> Copy
Edit --> Paste

Undo

After performing an editing function, e.g. deleting a block of text, you can undo 
the action by clicking on the Undo button at the top. The Undo function can also 
be invoked using the Edit menu selection at the top.

Saving Text

The text typed in can be saved by clicking on the File option on the main menu 
bar at the top and selecting,

File --> Save As...

Move to the folder you want to save the file in and enter the name of the file to 
save.

Find and Replace

The Find button can be used to locate a text string. By default this search is not 
case sensitive and will also locate the text if it is part of a word. These default 
options can be changed from the Find dialog.



The Replace button can be used to locate a text string and replacing it with 
another. Again the default options of non-case sensitive and matching part of a 
word can be changed.

The Find and Replace functions can also be performed using the Search menu 
selection at the top.

Opening A File

You can edit a text document already saved on the system by opening it. From 
the main menu at the top choose,

File --> Open

and select the file to open.

Preferences

Preferences can be set from the Preferences menu selection,

Edit --> Preferences

The Preferences you can set include the font, color and point size to be used, tab 
spacing, autowrapping, and autoindenting.

Help

More information on how to use KWrite can be obtained by selecting Help from 
the menu at the top.

Chapter 4: Using Common Mass Storage Peripherals

Besides the main components which make up the modern PC, there are many 
optional peripherals which can be attached to it. When these are properly 
utilized, they can contribute to make the computing environment and experience 
more convenient, productive and pleasant. The more common peripherals 
include:

printer
scanner
mass storage devices

In this chapter we shall be looking at how to access and use the common 
peripheral mass storage devices:

floppy disk drive
CD-ROM  drive
USB mass storage device



CD-RW drive

Setting up and using a printer and scanner will be covered in the next chapter.

Note: 
The method is to use the My Computer icon located on the Desktop. Double-click 
on the My Computer icon, and it will display all the system devices as well as the 
file system.

Fig. Accessing System Devices and File system in KDE

The Floppy Disk Drive

While most of the work is done using the hard drive (system and user data are 
stored on the hard drive), sometimes you may want to transfer or copy files to 
another PC. One convenient way to perform this (provided that the file sizes are 
not too large) is to use a floppy disk or diskette. Diskettes are very useful as a 
portable storage medium for small files (1.44Mb or less).

Mounting and Using the Diskette



Before a diskette can be used, you have to perform an operation called 
"mounting" the diskette. This is to let the system know that you are going to 
access and use the diskette in the floppy drive.

The KDE desktop environment uses a series of background processes to 
accomplish various tasks. Mounting drives is handled by the "Media" process. 
Simply click on the Storage Media icon in the System (My Computer) folder, and 
the Media task will be shown.

Fig. Storage Devices

Disk access is done by double clicking on the My Computer icon on the desktop. 
Double clicking on the "Storage Devices" icon will open the window seen above. 
Next, double click the "Floppy Drive" icon.

This will mount the floppy and add a floppy icon on the desktop. Double-clicking 
on this will list out the files and folders in the floppy under the File Manager as 
seen below:



Fig. Mounted Floppy

Once you have successfully mounted the diskette and listed out its directory 
contents under the File Manager, you can treat it like another folder to read and 
write files and folders to. However, you have to bear in mind some differences 
between the floppy diskette folder and the normal folder you have been working 
with.

The diskette has a very low storage capacity compared with the hard disk; a 
floppy diskette typically will have about 1.44 MB of storage capacity only. In 
contrast a hard disk will have at least a few hundred MB of storage capacity at 
the minimum!

If the write-protect tab on the diskette is enabled, then the diskette can be used 
for reading only, i.e. you can read the contents of the files on it only. You cannot 
write to the files, and so you cannot modify and/or create new files or folders.

After using the diskette, you will need to unmount it before you take the diskette 
from the floppy drive. To unmount the diskette, right-click on the floppy icon on 
the desktop and select "Unmount". This will unmount the diskette and the floppy 
icon will disappear from the Desktop. Once this has happened, you can safely 
remove the diskette from the floppy drive.



Note:
It is important that you unmount the diskette before removing it from the floppy 
drive, especially if it has been mounted for writing. Failure to do so may result in 
incomplete data being written to the diskette and corruption of the file system 
on the diskette.

Formatting the Diskette

Before a diskette can be used it has to be "formatted" first. This will create the 
directory structures and other information needed for the system to keep track 
of where the data is stored on the diskette. You need to format a diskette once 
only. You can subsequently format it again after using it for some time, but re-
formating will result in the loss of the original contents of the diskette.

KFloppy does not come with the default install. You can install it and several 
other useful utilities by opening the Synaptic Package Manger and installing 
kdeutils.

To format a diskette, you can use the KFloppy formatter selection from the Main 
Menu.

Main Menu --> System --> Configuration --> Hardware --> Utilities --> KFloppy



Fig. KFloppy Formatter Dialog

Choose the default floppy density of 3.5", 1.44 MB and the DOS (FAT) file system 
type. This will enable the diskette to be read on almost all commonly used 
operating systems including Microsoft Windows. You also have two other options 
for the filesystem; ext2 or Minix. Next, you can choose the type of formatting; 
Quick format, Zero out and quick format, or the default, Full format. After you 
have made your choices click the Format button located at the top right of the 
window.

Exercises

Format a floppy diskette, mount it for read-write and copy the following 
files/folders found in the /etc directory to it: hosts, termcap, motd and rc.d.
Unmount the diskette, mount it again and copy its entire contents to the folder 
tmp in your home directory (create this folder if it is not there). Unmount the 
diskette after the copying.



The CD-ROM Drive

Nowadays the CD-ROM is widely used as a means to store and distribute data 
and information. A typical 5.25" CD-ROM can store up to 700 MB of data. It is 
thus ideal as a medium for distributing large files, multimedia games, and 
software packages.

By default, when a CD-ROM is placed in the drive a new window will open that 
says "A new medium has been found. What do you want to do?" Below this you 
will see a list of options. Choose "Open in New Window" and whatever data is on 
the CD will be displayed in a new window. If it is an audio (music) CD it will be 
auto-mounted, and then the default KDE CD player, KsCD, will open on your 
desktop and begin playing the music on the CD.

Fig. New Medium Detected

The File Manager can then be used to access the files and folders on the CD. If 
the CD-ROM is a read-only medium, you can only read the contents of the CD 
and not write to it.



After using the CD, you will need to unmount it before you take it out of the CD-
ROM drive. To unmount the CD, right-click on the CD icon on the desktop and 
select "Unmount". This will unmount the CD and the CD icon will disappear from 
the desktop. It is now safe to remove the CD.

The USB Mass Storage Device

Another popular portable storage medium is the USB mass storage device 
(sometimes also known as a thumb drive). Like the floppy diskette, you can read 
and write to a thumb drive but it has the advantage of storing much more data 
than a diskette. Thumb drive devices of capacities 128MB up to 8GB are 
common.

To access the thumb drive, place it in the USB slot (port) provided and a window 
will open on the desktop. Choose "Open in New Window."

Fig. Removable Media dialog

This will mount the USB thumb drive and add a thumb drive icon on the desktop. 
Double-clicking on this will mount the USB thumb drive, add a thumb drive icon 
on the desktop, and list out the files and folders in the thumb drive under the File 
Manager. You can then treat it like another folder to read and write files and 
folders.



After finishing with the thumb drive, you will need to unmount it by right-clicking 
on the thumb drive icon on the desktop and selecting "Safely Remove", before 
removing it from the USB port.

The CD-RW Drive

While the CD-ROM drive is very useful as a portable storage medium due to its 
high capacity and low cost, it suffers from the disadvantage that it is a read-only 
medium.

To overcome this, many PCs are sold nowadays with drives which enable you to 
record data onto CD-R (CD recordable and CD-R(W) (CD rewritable) disks. The 
former refers to a CD medium which allows you to record to it only once, while 
with a CD-R(W) disk it is possible to rewrite data to it multiple times.

Note:
While a CD-R(W) drive supports both CR-R and CD-R(W) functionalities, the CD 
medium that you utilize determines whether you can write data to it only once 
(CR-R) or multiple times (CD-RW). So it is important that you buy the correct 
medium type for the function that you want.

K3b The CD-Burner

Your system has a program which enables a user to copy files and folders very 
easily to a CD-R(W) drive. To use this feature, start the K3b program from the 
Main Menu.

Main Menu --> System --> Archiving -->CD Burning -->K3b



Fig. K3b CD Burning Program

Top Window - Data Sources

The K3b window has 2 main window sections, top and bottom. The top window is 
divided into 2 windows, left and right. The left window shows a list of data 
sources; Unix Tree, Internal Structure and CDROM drives. The data sources are 
the sources for the data to be copied and burned into the CD-R(W).

The Unix Tree represents the file system on the computer. Clicking on the + icon 
of the tree will expand it to display the file system, i.e. the hierarchical tree 
structure comprising files and directories (folders). Clicking on a directory will 
cause the files in the directory to be displayed in the right panel of the top 
window.

Clicking on CDROM drives will expand into a listing of the CD-ROM drives 
present in the system and clicking on one of the drives will display the tracks in 
it on the right panel.

Bottom Window



The bottom window gives you 4 choices as to what you would like to do with your 
CD/DVD; Audio CD, data CD, or data DVD. The fourth choice is to make a copy of 
a CD. If these are not what you are looking for then you need to click on the 
"Further actions" tab to see a complete list of options available as seen below:

Fig. Further actions

Writing data to the CD-R(W) involves selecting which type of project you would 
like to create. After choosing which project, you can add the data from the data 
sources window described above by dragging and dropping them into the bottom 
window panel. The bottom window has three possible selections; the virtual file 
system, the track editor, and the recorder settings. Each of these can be selected 
by clicking on the icons in the left panel of the bottom window.

The virtual file system represents a view of the file system setup in a track of the 
CD-R(W) to be written to later. Note that this is not part of the actual file system 
on your computer and so manipulating the files here will not affect the ones in 
the computer file system. The virtual file system can be managed and edited by 
right-clicking the mouse.

The track editor shows you the tracks that you have selected to be burned to the 
CD-R(W). You can edit them using the track editor by right-clicking the mouse 
before committing them to be burned.



When you have added all the data or music that you would like to burn to the CD 
you need to click on the "Burn" button. This will open the burn window which 
enables you to change from the default, the various parameters for recording, 
e.g. recording speed, writing mode, etc.

Fillstate Status

At the bottom of the K3b window is the Fillstate status panel. This shows you the 
current space that will be taken up by the selected tracks as a percentage of the 
space available on the CD-R(W). This space utilization is also displayed in 
megabyte (MB) units as well as the audio playing time.

Duplicating CDs

It is easy to make a duplicate of a CD using K3b. To do this you will need one 
CDROM drive and one CD/RW drive. With K3b opened on your desktop, choose 
"Copy CD" and then insert the source CD into the CD drive. Next, insert the 
CD/R or CD/RW into the CD/RW drive. The drives will automatically be selected 
in the  Source Medium and Burn Medium windows. You will see a window like 
this:



Fig. CD Copy window

The only setting that you may want to change is the burn speed. Auto will select 
the speed for you but a tip to remember is that the lower the burn speed, the 
better the burn. To start the actual recording (burning) of the CD, click on the 
Start button at the bottom right corner of the K3b window.

Creating a Data CD

This section will discuss how you can copy files and folders from the mounted file 
system and record them into a CD-R(W). You can select the files and folders you 
want to copy from the Unix Tree in the Data Source window at the top left or 
from the top right window and drag them into the virtual file system right panel 
in the bottom window. The files and folders in the virtual file system can be 
edited by right-clicking on the mouse. You can create, delete and rename files 
and directories (folders).



After you have selected all the files you want, you should select the Burn button 
as above and then choose Start to start the recording.

Writing ISO Images

It is possible to copy and store all of the data on a CD in the form of what is 
known as an ISO image file format. If this ISO image file is then written to a CD, 
the new CD will be a duplicate of the original one from which the ISO image was 
created. This provides a convenient way of duplicating a data CD if you can copy 
or download the ISO image file from another source to the file system on your 
computer.

To write ISO images to a CD-R(W), select "Further actions" or "Tools" (at the top 
of the window) and select "Burn CD Image." This will open a window like the one 
seen below:



Fig. Burn ISO Image window

Next, select the ISO image by clicking on the file folder icon on the right side of 
the "Image to Burn" tab at the top left of the window and navigating to the ISO 
image file that you want to burn. Select the image by left clicking on it. Next, 
insert a blank CD-R(W) into your CD-R(W) drive. After that, ensure that the 
recording settings are correct and click on the Start button at the bottom right of 
the window to start the burning.

Help



There are many more options and features which K3b has, e.g. multisession 
burning, mixing audio and digital data, working with CD-RW media etc. The K3b 
documentation should be consulted for these more advanced features. The K3b 
User's Guide may be obtained from:

http://www.k3b.org

Chapter 5: Using the Printer and Scanner

While the holy grail of office computing may well be the paperless office, for 
many users, it is often desirable and indeed sometimes necessary to be able to 
put on hard copy the information available on the computer. The printer allows 
you to do that. The printer is essentially an output device with which you are 
able to output text and graphics onto paper from digital data stored on the 
computer. To complement this, the scanner is an input device with which you can 
transfer text and graphics from paper to the computer and store it in the form of 
digital data which can then be further manipulated by other software 
applications.

The Printer

Printer Setup and Configuration

If you have a printer attached to your system you will need to configure and set it 
up before you can use it properly.

Note:
To enable the system to detect your printer properly, you should turn on the 
printer before trying to configure it.

When you want to install a new printer, click on the PCLinuxOS Control Center 
(PCC) button located in your Panel. You will then need to enter the root password 
since you are now attempting to set and change some system parameters and 
configuration files. Choose the Hardware tab and then select; Setup the 
printer(s), the print job queues,... This will bring up a window that looks like this:

http://www.k3b.org/


Fig. Printer Config Screen

If all goes well you will see your printer listed in this screen. If so, you will need 
to click once on your printer to highlight it and choose the Edit selected printer 
icon. Choose Make Default and click on Do It. You are now ready to print. If this 
does not happen then while at the printer configuration screen click on the Add a 
new printer to the system  icon to add and configure a new printer. A new 
window will be opened that looks like this:



Fig. Add New Printer

This screen will explain your options for having the printer wizard auto detect 
any computers that are attached to your computer, or attached to another 
computer on your network. There is also an option to auto detect a printer 
attached to a computer running Microsoft Windows. Click on the Next button 
and the auto detection will be run. When it is finished you will be presented with 
a window that looks like this:



Fig. Detected Printers

By clicking Next, the detected printer will automatically be configured for you. 
You also have the option to configure your printer manually yourself, but this 
option should be used only if you know all the specifics necessary or if your 
printer was not found during the auto detection process.

If you choose manual configuration and click Next a new window will appear. 
Select the manufacturer of your printer, and then scroll down to find your 
specific printer. When you click Next, you will be taken to a screen that will show 
you the default settings for the selected printer. Clicking Next again will allow 
you to name your printer or you can go with the default name. Click Next one 
more time and you will be asked if you want to make this printer the default 
printer for your system. Choose Yes or NO and click Next again. You will now see 
a window where you can print either a text or photo test page. Go ahead and try 
one or the other or both and see if your printer is configured correctly. After your 
test page has printed and you are happy that your printer works correctly, click 
Next one last time. This will bring up a congratulation page that tells you that 
your printer is configured correctly. Click Finish and you are ready to print.

Managing Print Jobs

When you send something for printing from your application, the data to be 
printed is stored in the print spooler area and a print job is added to the print 



spooler queue. In this way many printing jobs can be carried out without waiting 
for the printer to finish printing a job first before accepting another printing job. 
The Print Manager is used for managing the print jobs associated with a given 
printer. The Print Manager can be found by going to Menu > System > 
Configuration > KDE > Peripherals > Printers.

The Print Manager can be utilized to check on the status of the printing jobs that 
you have submitted to the printer and to cancel jobs still in the queue if you need 
to. To do this, launch the Print Manager and then click on the Jobs tab. A list of 
current print jobs in the queue is displayed. To cancel a print job, highlight the 
job in question and then right click on the Remove button on the menu bar on 
top.

Fig. Print Jobs



Using the Printer

Normal usage of the printer from an application is straightforward. Select the 
printing function from your application and a print job is then automatically 
submitted to the printer queue.

The Scanner

The scanner is a device which allows you to convert analog graphics e.g. a 
photograph or a printed page into digital format where it can be stored on the 
computer and further manipulated by appropriate software. Flat-bed scanners 
for personal use are quite common nowadays.

Most scanners connect to the computer using the USB, SCSI or parallel ports. 
To use the scanner, suitable software to control and drive it is required. The 
SANE backend drivers may be used to drive the scanner hardware while the 
XSane GUI front-end acts as the end-user interface. To check whether the 
scanner you have can be used, the SANE website at http://www.sane-project.org 
should be consulted.

Using the Scanner

You can start the scanning software on the Desktop, from the Main Menu,

Main Menu > Multimedia > Graphics > Kooka

This will invoke the Kooka program; the main window in Kooka consists of three 
frames. At the top, see both icon and a menu panels. Use the mouse to enlarge or 
reduce the windows as needed.

Fig. Kooka Main Window

The navigation window consists of two tabs, which allow you to switch between 
the Preview and the integrated file browser called the Gallery. The working 

http://www.sane-project.org/


folder is displayed in the lower part of the window along with the folder where 
the scan will be saved.

Make your scanner-dependent settings, which are dependent on the scanner you 
have connected, in the lower left window. Usually, these are settings for 
resolution, brightness and contrast, scanning mode (e.g., color, gray, or binary), 
and for gamma values. Configure your settings here first.

Preview

Before the actual scanning of an image takes place, the preview operation is 
usually carried out to preview the scanned image. To perform the preview, place 
the image to be scanned into the scanner and initiate the preview scan with 
Preview. If the Preview tab in the upper window is selected, see the results there.

Select the various formats in the preview image itself to define the final 
dimensions. The User setting is recommended for this, so you select the area to 
scan in the preview display with the mouse.

Fig. Preview Window

As the scanner will scan its entire scanner bed by default, if you are scanning an 
image which occupies only a part of the bed you will want to select only the area 
which holds the image to be scanned. This can be done from the Preview window 
in several ways. One way is to manually select the scan area frame by pressing 
and holding the left mouse button to define one edge, moving the mouse so that 
the area to scan is completely inside the frame (which is marked by a dashed 
white line) and then releasing the mouse button. Another way is to select the 
Autoraise button and then clicking on the image to be scanned. A frame is 
created to mark the scan area. The mouse may be used to adjust the scan area if 
it is not fully correct.

Scan

After the appropriate scan area has been chosen in the Preview window, the 
image can be adjusted and/or enhanced for color correction, contrast, and 
brightness. The gamma value, brightness and contrast can be adjusted manually 
in the scan window before performing the scan.



After a satisfactory image is seen in the preview window, perform the actual scan 
by clicking on the Final Scan button. The scan will be performed and the scanned 
image displayed in the Viewer window.

Save

The method for saving an image is somewhat different in Kooka than in many 
other applications. Click the Gallery tab to open a small file browser. This is the 
folder ~/.kde/share/apps/ScanImages/ In the lower portion of the window, your 
current subfolder in the gallery is shown. This is where all scanned images are 
first saved as files. When starting Kooka for the first time, you will only see the 
ScanImages. Create subfolders by right clicking this folder. The selected folder, 
highlighted in blue, is the first save location of the scanned images. The scans 
are labeled in ascending numerical order as in kscan_0001 and kscan_0002.

To save an image permanently, left click the name. Next, give a new name and 
the appropriate ending for the image format chosen when scanning. If you enter 
a different extension, you will get a message that it does not correspond to the 
scanned format. Although you can still save the image under this name, it will 
retain its original format. At present, On-the-fly conversion is not offered.

If you do not want to use this method of managing your images in 
~/.kde/share/apps/ScanImages/, you can, of course, save them to another 
location. To do this, right click the image name and select Save. Choose any path 
here. In addition, close or permanently delete images here.

Help

More detailed information on how to use the scanner software as well as 
changing the default configuration can be obtained by clicking on the Main Menu 
and then on More Applications, Documentation, and then KDE Help Center. After 
the KDE Help Center opens choose KDE User Manual and scroll down to III. KDE 
Components > 6. The Base KDE Applications > Graphics and then scroll down to 
Kooka.

Exercises

Perform a scan of an entire photograph containing several people or objects.
Using the same photograph as for the previous exercise, this time perform the 
scan for only the image of one person or object.

Chapter 6: Accessing the Internet

The Internet has revolutionized information usage and dissemination. It has 
made the global village a reality whereby almost anyone, any where in the world, 
is reachable if the person has an Internet connection. The most common way to 
get Internet connectivity is by using the PC, be it at home, in the place of work, 
the community hall, or even a cybercafe.



In this chapter we shall examine some of the more common methods in which a 
PC can gain access  to the Internet.

The Internet Service Provider (ISP)

For a personal or home user, before you can access the Internet you will need to 
sign up with an Internet Service Provider (ISP). The ISP usually has a network 
which is connected to the Internet by a permanent telecommunication link, i.e. 
one can view the ISP's network as part of the Internet. The ISP provides the 
necessary networking infrastructure to enable you to connect to its network. 
Thus, once your PC successfully connects to the ISP's network, it can then access 
the resources and services provided by other computers on the Internet.

The Internet can be accessed from your system using a variety of methods, 
depending on the type of access methods supported by the ISP you sign up with 
and the type of networking devices you have installed in your system. Currently 
the most common methods of connectivity by a home or personal user to an ISP 
are:

dial-up
DSL or Cable Internet

Dial-up Connectivity

The simplest way to access the Internet is to use a dial-up telephone line 
connection. Almost all ISPs provide dial-up access connectivity to the Internet 
using the existing telephone line in the home or office. To do this you will need 
the availability of a telecommunication device called a "modem." Most modern 
PCs come with a built-in dial-up modem card or if it does not, you can purchase 
one and install it or purchase an external dial-up modem and use the serial port 
available on your PC for connection.

Before you can dial up to your ISP and access the Internet, you have to configure 
your system to recognize the modem and then dial the correct number to your 
ISP. You will need to have at hand the following information needed for the 
modem configuration:

telephone number to dial to the ISP for the Internet access
Internet access login name and password provided by the ISP

Modem Configuration

To configure your modem for Internet access, start KPPP from the Main Menu:

Main Menu > Internet > Remote Access > KPPP



Fig. KPPP Internet Dial-up Tool

Select the Configure button. Click on the New button.
You'll be prompted to Create a New Account. You could try the Wizard to set up 
your system, but if you live in the United States, the wizard will not find any 
ISP's. You'll need to use Manual Setup, but that's not difficult.
The Add button will prompt you to enter the phone number of the ISP (Internet 
Provider). If you need to use an area code and/or a dialling prefix to reach the 
ISP, you should enter them in the box provided, otherwise just enter the 
telephone number.
Enter the name you want this connection to be known by, usually the name of the 
ISP is used (this is is just a nickname provided by you so that you can recognize 
this connection). Enter the login name and the password in the boxes provided.



Fig. Filling in the ISP Provider Information

Don't worry about the IP Settings tab. Most ISP's assign IP addresses 
automatically (Dynamic IP). If not, you'll need to contact your ISP, and get the 
information from them. Then, just enter your IP address and related information 
by selecting the Static IP address button. 



Fig. Filling in the IP Settings

Click on OK to accept and end the set up.
The KPPP Configuration window will pop up; click on OK to exit from it.

Activating the Modem

To test your modem and Internet connectivity, select the KPPP tool from the 
Main Menu:

Main Menu > Internet > Remote Access > KPPP

Select the profile you have set up (remember the ISP nickname you used in the 
set up above?) by clicking on it and then click on the "Connect" button. The 
modem will start to dial and connect to the ISP and after awhile, upon successful 
login, the KPPP window will tell you that you are now connected to the Internet. 



You can now perform the web browsing and other services discussed in the Next 
few chapters.

To disconnect from the Internet bring up the Network Devices Control window 
and select the profile which was activated above and click on the "Disconnect" 
button.  You will be disconnected from the Internet. You can then quit the KPPP 
program.

Troubleshooting

If, for some reason, you do not hear any connection noises, then perhaps your 
modem was not detected and set up. You'll need to use the Modem tab, and click 
the New button to make some changes.

Fig. Adding a New Modem

To find out if your modem is automatically detected, click on the Query Modem 
button, and look for a series of little bars and indications that something is 
happening. If you don't see them, then your modem is probably not detected. 
That probably means that your modem is actually a Winmodem, which don't 
always work well with Linux (they are designed to only work with MS Windows).
If your modem is a Winmodem, then your best option is to purchase an external 
serial modem and attach it to an open serial port on the back of your computer. 
After you have done this repeat the Troubleshooting steps above.



Exercises

Perform an Internet dial-up connection using the modem on the system
Determine that you have Internet connectivity by accessing some well known 
websites
Disconnect from the Internet

xDSL / Cable Internet Connectivity

The dial-up Internet connection discussed above provides ready and easy access 
for places which have telephone infrastructure in place. However, it has the 
disadvantage that the maximum data transmission speed which normal dial-up 
technology can provide is about 56 Kbits per second. While this speed may be 
adequate for email text transmission and web browsing of non-multimedia 
intensive web content, it is not practical for multimedia access. For heavy 
multimedia content access using the Internet, a high speed link in required. For 
the personal or home user, broadband xDSL technologies make this possible.

DSL is an acronym used for the family of DSL (Digital Subscriber Line) 
technologies which enable high speed data transmission through telephone lines. 
There are different types of DSL and they include, ADSL, SDSL, IDSL. 
Collectively these are known as DSL. ADSL (Asynchronous Digital Subscriber 
Line) is commonly used for the home.

xDSL / Cable Internet Configuration

There are two main types of DSL configuration in use and most ISPs use either 
one of these:

DHCP over Ethernet
PPoE over Ethernet

Usually if you have to use a login id and password for your broadband DSL 
connection then you should be using the PPoE configuration.

DHCP over Ethernet

Linux has been called "The Broadband OS" because it is very good at detecting 
and using Ethernet as it's main networking capability. The Quick Start way to set 
up both DSL and Cable Internet is to plug the Ethernet cable (which looks like a 
phone cable, but with 5 strands of wire instead of 3) into your modem's Ethernet 
port, and the other end of the cable into your computer's Ethernet port.

Most modern day flavors of Linux will autodetect an active Ethernet connection, 
and assign it to the device name eth0, eth1, and so on. If there is more than one 
Ethernet interface for your computer, the "ethX" numbers will increase.



For this configuration, what is needed is just to obtain the IP configuration 
parameters using DHCP (Dynamic Host Configuration Protocol). To set up your 
DSL connection click on your PCLinuxOS Control Center (PCC) icon in your 
panel and enter your Root password. Next, choose the Network & Internet tab 
and then choose "Setup a new network interface (LAN, ISDN, ADSL,...)." You will 
then see a screen like the one below:

Fig. New Connection

Select Ethernet connection in the select device type screen and click on the 
Forward button. A screen showing the detected Ethernet card(s) on your system 
is displayed as seen below:



Fig. Select Ethernet Device Screen

Select the correct Ethernet network interface. (You usually have only one 
Ethernet card installed on the system.) Click on the Next button.

The default is to select your IP automatically. You should accept this and all the 
defaults on the next few pages.



Fig. connection protocol

Clicking next will bring up a window where you can enter the login name and 
password provided to you by the ISP. Click on the Next button. 

On the next window check the box next both "Allow users to manage the 
connection" and "Start the connection at boot" and click Next.

Click next and you will see a window that will ask if you want to start the 
connection now. Choose yes, click next, and you will see a congratulations 
window. Click on Finish to accept and end the set up.

Activating the ADSL Link

To test your ADSL link and Internet connectivity, click on your PCLinuxOS 
Control Center (PCC) icon in your panel and enter your Root password. Next, 
choose the Network & Internet tab and then choose Monitor network 
connections from the screen below:



Fig. Network and Internet

If you are using DHCP over Ethernet, select the Ethernet device name (usually 
this is eth0) you have used in the configuration set up by clicking on it and then 
click on the "Connect" button.

If you are using PPoE over Ethernet, select the ISP name you  used in the 
configuration set up by clicking on it and then click on the "Connect" button.

The link will be established after a few seconds and the status of the profile in 
the Monitor network connections screen will change to "Connected" from "Not 
Connected." You are now connected to the Internet.

Exercises

Perform the same Internet connectivity tests as done previously with the dial-up 
modem connection.

Chapter 7: Multimedia Graphics Access



Multimedia Access and Players

Apart from being able to view and create graphics and other images, the PC is 
capable of supporting a wide range of audio and video features and facilities. 
These include the playing of audio CDs, audio digital files, VCD and DVD as well 
as multimedia games.

Note:
While support may be available in the software, the necessary hardware has to 
be available before these multimedia facilities can be used, e.g. a DVD drive is 
required to be present on the system before you can play a DVD.

By default most modern PCs come with a CD-ROM drive capable of playing audio 
CDs and VCDs as well as a sound card and speakers. As such in this chapter we 
shall discuss how you can listen to an audio CD, play audio digital files and view 
VCDs.

In the following sections we shall be discussing several media players. Some of 
these e.g. mplayer and xine are multimedia players in that they can be used as 
generic players for audio CD, digital audio files, VCD and DVD.

The Volume Control Applet

Since almost all the multimedia applications require some form of audio 
production and mixing, it is useful if we know how to control the various 
channels of audio available from the sound card using the Volume Control Applet 
on the Panel. This may be launched by right-clicking the Volume Control icon on 
the Panel and selecting Open Volume Control. If it is not there you can also 
launch it form the Main Menu:

Main Menu -> Multimedia -> KMix



Fig. Volume Control Applet

KMix is essentially an audio mixer which enables you to mix the audio for a 2-
channel sound card. Every mixer control that your sound card provides is 
represented by a volume slider. Mono controls always have a single slider while 
stereo controls can have either one or two sliders, depending on your settings. 
There is also a panning slider at the bottom of the window. If your system has 
more than one sound card, a list will be displayed at the top of the window.

The KMix window can have up to three different sections, Output, Input, and 
Switches. Each section will contain volume sliders, switches for 
enabling/disabling record or playback functions, and multiple choice selectors.

Output: This tab holds the controls that are most likely related to playback, like 
the Master volume control.

Input: This tab holds the controls that are most likely record related, like 
Capture.

Switches: These controls allow you to switch certain functions On and Off, like 
External Amplifier.

KMix also features LED´s. The general coloring rule is as follows:

Green: An LED dealing with playback
Red: An LED dealing with recording
Yellow: An LED dealing with special sound card capabilities



A lit LED means On, a non-lit LED means OFF.

In most situations the volume can be adjusted by clicking on the Volume Control 
applet on the Panel and raising or lowering the slider accordingly.

Playing Audio CDs

You can play an audio CD by placing the CD into the CD-ROM drive. The CD 
player application (KsCD) will be run automatically to play the CD. Ensure that 
your speakers are turned on so that you can hear the CD! You can also manually 
start the CD Player application from the Main Menu:

Main Menu -> Multimedia -> Sound -> KsCD

Fig. CD Player

You can control the CD Player just like a normal CD player with the buttons 
shown on the CD Player screen. These include volume control, track 
forward/backward, play/pause, stop, eject as well as jumping to any track on the 
CD directly.

Playing Digital Audio Files

PCLinuxOS gives us Amarok which is arguably the most complete music 
manager available today. Amarok serves many functions rather than just playing 
music files. For example, Amarok can be used to organize a library of music into 
folders according to genre, artist, and album, can edit tags attached to most 
music formats, associate album art, attach lyrics, and automatically "score" 
music as you play it.



Fig. Amarok

Amarok plays media files in various formats including but not limited to 
(depending on the setup), Flac, Ogg, Mp3, AAC, WAV, WMV, and Musepack.

Note: Amarok will not play digital music files protected by DRM, such as those 
purchased from the Itunes Music Store.

It also can Sync, retrieve, play, and upload music to digital music players, such as 
Ipods or Creative Zens.

Note: To work with Creative Zens or other MTP devices, libmtp0 will need to be 
installed from the repositories.

One last notable feature is Last.fm support, including submitting played tracks 
(including those played on some digital music players) to Last.fm, retrieving 
similar artists, and playing Last.fm streams.

You can find Amarok by going to:



Main Menu -> Multimedia -> Sound -> Amarok

Another excellent player that in the repositories and can be easily installed is 
XMMS. The XMMS (X Multimedia System) application can be utilized to play a 
wide variety of digital audio file formats. These include the popular MP3 as well 
as the open Ogg Vorbis formats. To launch XMMS, (after it is installed) select:

Main Menu -> Multimedia -> Sound -> XMMS

Fig. XMMS Player

Note:
XMMS may need additional plug-ins to be able to play some of the audio file 
formats. If these are not already installed on your system they can be installed 
from the repositories using Synaptic.

You can control the XMMS player using the graphical knobs and buttons 
displayed. In addition, you can select the source of the audio files to play. To do 
this, right-click on the XMMS player and from the pop-up menu select "Play File" 
to select the audio file to play. If you want to be able to play an audio file from 
the Internet select "Play Location" and enter the Internet location of the file.

Playing VCD and DVD

There are several excellent applications readily available for you to use to play 
VCD and DVD media. Here we shall look at two of them: Kaffeine and Mplayer. 
These can also play CD and digital audio music files.

Kaffeine

The Kaffeine application may be used to play VCD and DVD. You can start 
Kaffeine from the Main Menu:



Main Menu --> Multimedia --> Video -> Kaffeine

The Kaffeine user interface is highly intuitive as it resembles a normal VCD/DVD 
player with all the basic control knobs and buttons.

Fig. Kaffeine Control Panel

To play a VCD, place the VCD into the CD-ROM drive and click on the Play VCD 
button on the Kaffeine control panel.

To play a DVD, place the DVD into the DVD drive and your movie should start 
playing. If it does not then right click on the DVD icon on your desktop and 
choose "Play DVD with Kaffeine."

The volume control can be adjusted by clicking on the volume control button.

Kaffeine is a very powerful multimedia application with many features. It can 
also play audio CDs as well as digital audio files.



Note: to be able to play encrypted DVDs you will need to install libdvdcss and 
win32codecs from the repositories using Synaptic. You will need to check to see 
if the use of these libraries is legal as it is considered illegal to use this in certain 
parts of the world.

MPlayer

MPlayer is a popular movie player for Linux. In addition to being able to play 
VCD and DVD it is also able to handle a wide variety of audio and video file and 
streaming data formats. Hence it is useful to use Mplayer as the universal 
multimedia player. The Mplayer GUI can be started from the Main Menu,

Main Menu -> Multimedia -> Video ->MPlayer

On start up, the main Mplayer control screen and the Mplayer video output 
screens are displayed.

Fig. Mplayer Control Screen



Fig. Mplayer Video Screen

The control screen enables you to control the operations of Mplayer while the 
video screen displays any video that is being played. In addition, right-clicking 
with the mouse when it is inside either the control or video screens will also 
bring up a menu for controlling the use of Mplayer.

The Mplayer control screen enables you to perform the following:

start, stop and pause play
go to the next and previous stream
jump to the first and last tracks
adjust the sound balance
adjust the volume and mute
select files to play
set up a playlist
set the video and audio equalizer
configure preferences
exit the Mplayer application



All of the above functions are represented by intuitive knob, dial, and button 
icons on the control screen making it very easy to use Mplayer.

To play a VCD, place the VCD in the CD-ROM drive, move the mouse over the 
control screen or video screen and right-click it. Select,
VCD -> Open disk

To play a DVD, perform the above for VCD but instead select,
DVD -> Open disk

The size of the video screen can be controlled by right-clicking on the mouse and 
selecting normal size, double size or full screen. When you are in the full screen 
mode, to return to normal size, right-click on the mouse and select normal size.

Exercises

Play an audio CD using the KsCD Player
Play an audio digital music using Amarok
Play a VCD or DVD using Kaffeine and MPlayer

Graphic Images Access

Very often it is useful if we are able to view graphic image files on their own, or 
in thumbnail fashion if there are many of them. It is also useful if there are 
simple tools available which will enable us to manage these image files, e.g. 
catalog and classify them and recall them for viewing. In this section, we shall 
look at several tools available on your system which provide some of these 
functionalities.

File Manager

The File Manager itself provides a simple and convenient means to access and 
view image files. To view an image file from the File Manager, move your mouse 
pointer over the file and a larger thumbnail picture will appear. To view the file 
full size double click on it. Another convenient way of viewing when you have a 
lot of files in a folder is to select the "View Mode > Photobook" option from the 
View menu selection.



Fig. Photobook View in File Manager

This will result in only the image files present in the folder being displayed. You 
can then select an individual image to view and also perform zoom in or zoom 
out views.

digiKam Camera Access

digiKam is a simple digital photo management application, which makes 
importing and organizing digital photos a "snap". The photos can be organized in 
"albums" which are automatically sorted chronologically. An easy to use interface 
is provided to connect to your camera and preview images and download and/or 
delete them.

digiKam uses a folder on your file system as an album library, meaning that every 
sub folder of this folder will be considered as a photo album and displayed in the 
album list on the left side of the main window. 

Clicking on an album will start showing the thumbnails for the images in the 
album. You can change the icon size to small, medium, large or huge from the 



magnify buttons in the toolbar. Right Clicking on an item will give you a pop up 
menu, using which you can view, rename, delete, see the exif information, and 
add/edit comments of the images. Double clicking on an item will open it up in 
the image viewer.

Fig. digiKam Photo Manager

To be able to use your digital camera with digiKam, connect the camera to your 
computer, switch the camera to the image display mode and turn it on. If your 
camera is detected as a mass storage device (ex. sda1) a "New Medium Found" 
window will be displayed on your desktop along with an icon. If this does not 
happen when you plug your camera in and turn it on then you will need to setup 
the camera model and port using the setup interface. Try and see if digiKam can 
auto-detect the camera; if not, you can set the camera model and port manually.



Fig. Camera Configuration

Once you have the camera setup, go to the "Cameras" menu in the main 
interface and you will see the camera listed in the menu (Note: You can choose 
any title you like for the camera in the setup and this title will be used in the 
"Cameras" menu). If you have more than one camera, you can add them 
throughout the setup interface.

Clicking on the camera item in the menu will pop up a new Camera Interface and 
this will connect to the camera, and thumbnails (if supported by the camera) will 
be downloaded and displayed. You can then select the images and download or 
delete them from the camera. Downloading can be done by using the 
menu/toolbar buttons or by dragging and dropping them onto an album folder or 
any other folder that you choose.

Digital cameras nowadays store images on either a CompactFlash card, SD card, 
or SmartMedia card. The camera internally makes sub folders in these storage 
media which it uses to save the images. digiKam displays these internal folder 
trees and also provides a global virtual folder which shows all the images 
available in the camera.



When you open the camera interface for the first time the folders are hidden and 
the contents of the global virtual folder are shown (i.e. all the pictures in the 
camera). You can choose to see the actual folders on the camera by unselecting 
"Hide Folders" in the "View" menu. This will show the folders on the camera, the 
topmost folder being the global virtual folder. Clicking on a folder will show the 
contents of the folder in the thumbnailview.

Fig. digiKam Camera Client

showFoto Image Viewer

The showFoto image viewer is a powerful tool for viewing, and organizing 
graphic image files. To start this application perform:

Main Menu -> Multimedia -> Graphics ->showFoto



Fig.  showFoto Image Viewer

View

The simplest way to view an image is to double-click on the name of the image 
and it will be displayed in full. You can also navigate to the next/previous image 
as well as go to full-screen viewing. The Zoom function can be used to zoom in or 
out of  the image currently being displayed. Click on the Folders button at the 
top of the screen to go back to the thumbnail view. A preview of the image will be 
displayed in the preview area if you just select the thumbnail.

One useful feature of showFoto is the slide show. After a folder has been opened 
(File > Open folder), selecting View > Slide Show will start a full screen slide 
show of the images in that folder.

Image Manipulation

You can also manipulate the images under showFoto. Some supported functions 
include rotation, flipping, resizing, and Blowup. To access these functions select 
"Transform" from the menu bar at the top. Additional tools for working on your 
graphics files can be found under the Fix menu.



Convert Format

The Save As function of showFoto allows you to convert your image files from 
one format to another. Some of the 14 supported formats are:

Portable Network Graphics (PNG)
Joint Photographic Experts Group (JPEG, JPG)
Tag Image  File Format (TIFF)
TARGA format  (TGA)

To use the Convert function, select an image first and then from the top menu 
bar, select,

File -> Save As

and choose whichever format you would like to save to from the drop down list.

Help

showFoto has many other useful features.  The online help guide should be 
consulted for more details on how to use showFoto.

showFoto Handbook

Exercises

Use showFoto for the following:
View the images in the following folder: usr/share/backgrounds/images
View a slide show of the images in the folder above.
Copy one of the images from the above folder into your home directory and scale 
it down to 25% of its original size and save it.

Chapter 8: The World Wide Web (WWW)

The Internet has much to offer in terms of information on almost any subject 
matter imaginable and interaction with people and organizations from all over 
the world. Much of this access and interaction make use of the environment 
which is popularly known as the World Wide Web (WWW) or web. The WWW is 
an interlinked network of systems, called web servers, offering multimedia 
services and information. A user can access these using what is known as web 
browser software.

The Firefox Web Browser

Firefox is a full-featured integrated web browser, news reader and web page 
composer program, and is the default web browser for PCLinuxOS 2007. Using 
Firefox a user can be exposed to the richness and diversity of multimedia content 
and services available on the WWW.

http://docs.kde.org/development/en/extragear-graphics/showfoto/index.html


Firefox is a relatively lightweight and fast browser. The most distinguishing and 
advantageous feature is the sheer number (literally hundreds) of extensions (add 
ons) that can be downloaded and installed. Using these  add-ons; the user can 
personalize Firefox exactly how they want Firefox. For more information and 
descriptions of the over one thousand available add ons take a look at 
http://www.Firefox.com/firefox.

To start Firefox, click on the Firefox icon on the panel or launch the application 
from the menu system:

Main Menu -> Internet -> Web Browsers -> Mozilla Firefox

Fig. The Firefox Web Browser

By default the web browser component of Firefox will be executed and displayed. 
The navigation window has the following main parts by default.

the navigation toolbar
the menu bar
the display panel
the side bar (optional)

http://www.mozilla.com/firefox


(Firefox has many features and only a brief description of its main functionalities 
and features can be given here. The user should refer to the Help button on the 
menu bar for more details.)

The Navigation Toolbar

Fig. The Navigation Toolbar

The navigation toolbar allows you to access a website by entering its Uniform 
Resource Locater (URL) or more informally known as its web address, e.g. 
http://Distrowatch.com in the address box provided. Actually you need to enter 
only the name of the host i.e. "Distrowatch.com" and Firefox is smart enough to 
figure out that you want to access the web server on that host.

Clicking on the arrow at the right edge of the address box will open a pull-down 
menu showing a history of websites visited previously. You can click on an entry 
in the list to select that website.

Also present on the navigation toolbar are the Back, Forward, Reload and Stop 
buttons.

The Back button enables you to go back to the previous web page displayed.

The Forward button enables you to go forward to the next  web page that you 
have already accessed.

The Reload button forces Firefox to re-access the website and load the current 
web page.

The Stop button halts the loading of a web page that is currently proceeding.

Next to the address box in the navigation toolbar is the Search button. This 
button enables you to perform searches for relevant web pages on the Internet 
by making use of the Google search engine. To search for some particular 
information, you can enter the keywords for the search into the address box and 
then click on the Search button. As you type each letter a list of possible 
searches will be displayed below the search box. Quite often, what you are 
searching for will show up in the list before you finish typing. If so, simply click 
on the one you want to try. The results of the search will be displayed in the 
display panel. You can configure the search engine to use with this search button 
in the Firefox configuration setup (see Configuring Firefox below).

The Menu Bar



Fig. The Menu Bar

The menu bar has several menu buttons. Clicking on one will open up a drop-
down menu selection where selected operations can be performed.

The File button caters to the performance of file level operations like the printing 
and saving of web pages, the opening of web pages, files etc.

The Edit button allows you to find strings of text on the displayed page as well as 
to edit the Firefox configuration to you personal preferences.

The View button allows you to control the viewing of the various toolbars as well 
as the zooming of text and full page display of the display panel. The HTML 
source code of the currently displayed page can also be viewed using the 
selection "Page Source" under this button.

The History button performs similar navigational functions as the navigation 
toolbar described earlier. A history of previously visited sites can also be 
accessed by this button. The menu shows a list of previously visited websites and 
you can click on one of these to open up the selected web page.

Fig. The History Pop-up Window

The Bookmarks button enables you to manage your bookmarks and personal 
folder. You can add frequently visited sites to the bookmark and/or personal 
folder. To manage and organize your bookmarks you can select the "Organize 
Bookmarks" item in the drop-down menu.



Fig. The Bookmark Manager Pop-up Window

The bookmarks can be organized into folders by dragging and dropping them 
into the desired folder. New folders can be created by clicking on the New Folder 
button at the top. Folders can have a name and description. To separate and 
group together related folders, a separator line can be drawn by selecting the 
"New Separator" button.

The Tools button enables you to navigate and use specific tools and add ons in 
Firefox.

The Help button contains the Firefox help files arranged in user-friendly web 
page style and format.

The Side Bar

Under the View button you will find an option to add a side bar. The Side Bar is 
displayed on the left of the main display panel. This side bar can display your 
History, or your Bookmarks for quicker access.

The side bar can be turned on/off by selecting from the main menu at the top,

View -> Sidebar

The Main Display Panel

This is the area where the contents of a web page are rendered and displayed. 
This display area can be made full screen by either selecting the View -> Full 
Screen selection from the top menu bar or pressing the F11 key. To disable full 
screen display either press F11 again or click on the "Restore" window button on 
the top right corner of the menu bar.

Navigation Tab Bar



Firefox allows you to browse multiple websites within one browser window by 
using navigational tabs. This overcomes the inconvenience of opening several 
windows under Firefox to view multiple sites. To do this, either choose under the 
menu bar:

Edit -> Preferences ->Tabs ->New Pages Should Be Opened In ->A New Tab

or enter CONTROL-T.

If you open different web pages using this navigation tab feature, they will all be 
displayed under the same window. You can then use the tab bar to move between 
each tab screen.

Configuring Firefox

Firefox is highly configurable. To configure Firefox, select from the main menu:

Edit -> Preferences

The categories available for configuration are listed on the top panel of the main 
configuration window as seen below:



Fig. Firefox Preferences

The Main tab allows you to set your homepage and where to save files that you 
download.

The Tabs tab allows you to set all the options related to tabbed browsing.

The Content tab lets you block pop-ups, whether you would like to have images 
load automatically, and javascript control. You can also set your default fonts and 
configure how Firefox handles different file types.

The Feeds tab allows you to choose which feed reader to use when accessing live 
feeds from the Internet.

The Privacy tab lets you manage your History, Cookies, and Personal Data.

The Security tab allows management of passwords for different websites, 
warning messages, and whether websites are real or not.



The Advanced tab lets you control encryption, updates, and navigation within 
web pages.

Exercises

Start up the Firefox browser and visit the websites listed below. Use the 
navigation tab bar feature so that you open up the websites all in the same 
window, but under different tab pages.

www.Firefox.org
www.yahoo.com

Bookmark the sites visited above.
Configure Firefox so that it starts with your preferred homepage.

Finding Information on the Internet

The Internet is a treasure house of information. Virtually information on any 
topic under the sun (and more!) can be found on the Internet. However, while 
information is easily available, it may not be so easy to find the information you 
want. This is because the information may be available from very many sites, 
often in varying details, and varying aspects of the same piece of information. To 
assist us in finding information more effectively, a search engine or Internet 
portal may be used.

Note:
Information obtained from the Internet should be scrutinized carefully and not 
taken as "correct" in all cases. This is because due to its free flowing nature and 
easy means of access and creation, anyone can publish information on the 
Internet. As such, unless one is certain that the information is from an 
authoritative and reliable source, it should be verified by another source or 
means as far as possible.

Using a Portal

The term portal is used to denote a website that acts as an gateway for providing 
information about a subject area or  group of subjects.  From this portal site, 
information as well as links to other sites providing information about the topics 
in question may be found.  Portals are useful starting places for new web users 
who do not know where and how to go and look for information about a specific 
topic or subject.

Many major ISPs provide portal-like information services for their subscribers so 
that if the latter make this their home page for their web browser, on launching 
their browser the ISP's portal page is opened. The subject areas covered by 
these ISP portals are typically subjects of general interest like shopping, local 
and foreign news, entertainment etc.

http://www.yahoo.com/
http://www.mozilla.com/en-US/firefox/


Fig. Home Page for an ISP

Other portals offering general information as well as links to other more subject-
specific portals and websites include:

Yahoo (www.yahoo.com)
Netscape Network (www.netscape.com)
Microsoft Network (www.msn.com)
Angelfire (www.angelfire.lycos.com)

Using an Internet Search Engine

While portals provide a guided and categorized means to access information, 
sometimes we want to be more specific about the topic we want to find and 
portals generally are not able to provide this in a timely and efficient manner. An 
alternative is to utilize a search engine.

A search engine, as the name implies, allows you to query it about some specific 
subject and it will try to retrieve links to web pages and resources which contain 
information about the subject matter being queried.

The popular search engines available are:

Google (www.google.com)

http://www.google.com/
http://www.angelfire.lycos.com/
http://www.msn.com/
http://www.netscape.com/
http://www.yahoo.com/


Altavista (www.altavista.com)
Lycos (www.lycos.com)
Yahoo (www.yahoo.com)

There are also sites which allow you to search using more than one search 
engine, e.g.

Search.com (www.search.com)
Easysearcher (www.easysearcher.com)

Search Basics

While each search engine will have its own technology, its utilization to perform 
a simple and basic search is essentially the same, irrespective of which search 
engine is used.
 
To use a search engine for basic searches, you just type in a few descriptive 
words about the item/subject you are searching for. It will return to you a list of 
links to web pages and resources which contain all the words in the query string. 
Note that common words like "the", "a", "how", etc. are usually ignored by the 
search engine unless specifically told not to. Words are also not case sensitive 
unless enclosed by quotation marks. To refine and narrow down your search, you 
will need to add more words to the search terms you have already entered. Your 
new query will return a smaller subset of the pages found. You can also add a 
specific year (ex. Pearl Harbor 1941.)

http://www.easysearcher.com/
http://www.search.com/
http://www.yahoo.com/
http://www.lycos.com/
http://www.altavista.com/


Fig. A Search Engine

The basics of using current search engines is essentially keyword matching and 
so it is important to be able to identify appropriate keywords so that your search 
is more efficient and false hits are minimized. The keywords entered should be 
as specific as possible in order to get better results.

More details on how to use each particular search engine are available on their 
respective websites and they should be consulted so that you can make efficient 
use of them.

Example

In this section we shall show an example of how to use a search engine.

In this example, assume that we have heard from a friend that she has been 
diagnosed with a foot condition in which her forefoot is in pain and there is 
numbness as a result of poor blood circulation in one of the toes. We also 
remembered her telling us that the doctor named the condition as Freiberg 
disease, or some name which sounds like that since the telephone line was not 
too clear.

Initially we try entering the following keywords, "foot pain", in the search engine.



Fig. Search using Common Keywords

As can be seen from the results of the search, what we got back was very general 
and we need to go through each of these links to check if it contains relevant 
information or links to relevant information. We can narrow down the search if 
we are more specific about where in the foot the pain is, e.g. "forefoot pain." This 
will give us better results, but the list of hits is still long.



Fig. Search using Relevant Keywords

If we remember that the friend mentioned that the doctor gave the name of the 
condition as something sounding like Frieberg disease, we can try searching for 
this specific term. The search results improve immediately as can be seen below 
and in this particular example we have found several links which are directly 
related to the information we want.



Fig. Refined Search using Specific Keywords

That is the end of this chapter in our journey into the inner workings of KDE and 
PCLinuxOS 2007. In our next chapter we will be covering all of the ins and out of 
Internet e-mail including how to setup an e-mail account, manage your mail, and 
a couple of different e-mail clients. See you next month!

Chapter 9 – Internet E-mail

Internet e-mail has become one of the most popular applications on the Internet. 
An Internet experience is not complete without the usage of e-mail. In this 
chapter we shall be describing two commonly used e-mail software: KMail and 
Mozilla Thunderbird.

Email Requirements

There are two main types of Internet email systems: webmail and POP3. 
Webmail, as the name implies, makes use of a web browser to read, compose, 
send, and manage your mail. POP3 e-mail makes use of a POP3 email client to 
download your email from a server housing your email mailbox. The main 
difference between a webmail system and a POP3 e-mail system is that for the 
former, generally, you have to be online to the server housing your mailbox to 
access and manage your mail. For the POP3 system, you need to be online to the 



server only to download your mail, after that you can go offline to read, reply and 
manage your local mail storage.  You only need to go online again when you want 
to send out your e-mail.

In addition to having a webmail account somewhere on the Internet, webmail 
needs only a web browser and Internet access to work. Examples of popular 
webmail services are those from Yahoo and Hotmail. Most ISPs also offer 
webmail services in addition to their traditional POP3 e-mail services.

To use POP3 email you will need to have a POP3 email client software running on 
your computer. Linux has many different email programs which support POP3 
email. In addition, you will also need to know the name of the server on which 
your POP3 mailbox is located (the POP3 server), as well as the name of the 
server which allows you to send out (relay) mail through it (the SMTP server.)

Note:
Of course you will need to know your Internet email address irrespective of 
whether you are using webmail or POP3 e-mail!

Since the usage of  webmail involves using your browser mainly, all you have to 
do is go to the website of your e-mail provider (ex. Yahoo.com) and after logging 
in, click on the mail tab. Next, we will be looking at the POP3 setup and usage of 
KMail and Mozilla Mail.

KMail

KMail can be launched from the Main Menu:

Main menu -> Internet -> Mail -> KMail

Invoking KMail for the first time will bring up a dialog box that informs you that 
this is the first time you have used KMail and asks if you would like to set up 
your e-mail account.



Fig. KMail Welcome

If you click "Next", a new dialog box will appear. This box contains five choices 
that represent the different types of mail accounts that you would be likely to use 
with KMail. Since most people use POP3 we will cover setting this choice up.

Fig. Account Type

Highlight "POP3" by left clicking once on it and then click "Next." This will bring 
up the next dialog box which will allow you to enter your account information.



Fig. Account Information

In this dialog box you will enter the information needed for KMail to identify the 
account that you wish to send and receive mail with.

In the "Real name" box you should enter the name that you want to identify who 
you are when sending mail.

In the "E-mail address" box you need to type in the e-mail address that was 
provided by your ISP.

In the "Organization" box you can enter the name of your business, organization, 
or leave it blank if this is for use with your home computer. When you have 
finished entering your information click "Next." You will now see the Server 
Information dialog box.



Fig. Server Information

In this box we will enter the names of the servers that will be sending and 
receiving your mail for you. Your ISP should have provided you this information 
so just type in the name of your POP server (this one retrieves your mail) and 
then your smtp server (this one delivers your mail.) If for some reason you would 
like to use a secure connection you can mark the box next to "Use secure 
connection (SSL)." This will require you to configure SSL which is beyond the 
scope of this article. When finished click Next.

Fig. Login Information

As you can see from the figure above, our next dialog box is for your login 
information. You probably chose your own login name and password, and your 
ISP approved it, so you should have this information at hand. Go ahead and enter 
your login name first and then your password. KMail will use this information to 
gain access to your ISP´s pop-server to bring your mail to your computer and 
also to send your mail through your ISP´s smtp-server. Once this information is 
entered, click next, and you should see KMail main screen as seen below:



Fig. KMail Main Window

Optionally, once you have reached the main window you can use "Configure 
KMail" to modify almost every aspect of KMail. You can find it by clicking on 
"Settings" in the toolbar at the top of the window.

Receiving Mail

To receive your mail you can click on the "Check Mail In" button. It is the fourth 
button from the left, on the second toolbar as seen below:



Fig. Receiving Mail

If you would like KMail to fetch your mail automatically each time you open it, 
you will have to go to:

Settings ->Configure KMail

and then click on the "Accounts" tab as seen below:



fig. Receiving Mail 1

Once you have reached this window simply click on the box to the left of "Check 
Mail On Startup" and then click "Apply." Clicking on OK will close this window 
and the next time you open KMail, your mail will show up automatically.

Only a very brief description of the functionalities and features of KMail are 
given here. The user should refer to the Help button on the menu bar for more 
details.

Inbox Folder

The Inbox houses the email sent to you which you have downloaded from the 
POP3 server. To see what is in your Inbox click on the Inbox icon. If you have 
emails in your Inbox, they will be displayed here. To read an email select it by 
clicking on it in the Subject Window.



Fig. KMail Inbox

Composing Emails

To compose an email, from the Inbox screen, click on the New button.

Enter the email address of the recipient as well as the subject. The latter should 
be a few words describing the contents of the mail, but it should also not be too 
long. If you need to CC the mail to another email address, click on the View 
button on the top Menu bar and select CC field which will be displayed. After 
composing the email, you can send it.



Fig. KMail Composing Email

Offline Mode

If you are on a dial-up connection, it is very likely that you will want to compose 
all the emails that you want to send offline first before actually going online to 
send them. To do this, click on the File item on the menu bar at the top and 
select "Work Offline"

File -> Work Offline

(if the File menu shows the item Work Online then it means that you are already 
offline, i.e. It is a toggle between online mode and offline mode.)

In the offline mode, when you compose and send your mail they will not be sent 
out, but rather they are stored temporarily in your Outbox folder. You can send 
them off later after connecting to the Internet by selecting:
File -> Send queued messages

Sending and Receiving Emails

To send the emails you have composed, connect to the Internet first and then 
select Work Online from the File menu. Click on the Check Mail In button to 
receive mail, and click on the File -> Send Queued Message menu item in the 
menu bar. Unsent mail in your Outbox will be sent out and any incoming new 
mail will be placed in your Inbox.

Deleting Emails



Any mail deleted from your Inbox will be placed in the Trash folder. You should 
periodically empty the Trash by clicking on File from the menu bar and selecting 
Empty All Trash Folders. Alternatively, you can right click on Trash and choose 
Empty Trash.

Folders

Mail messages in KMail are organized in folders similar in concept to the File 
Manager. To view your KMail folders, click on them in the left side of KMail.

By default the following email folders are created under the Local Folders: Inbox, 
Outbox, Sent , Drafts and Trash. There is also a Templates folder. You can create 
a new folder by right-clicking on Local Folders, selecting New Folder and enter 
the Folder name. You can move and copy mail messages between folders by 
right-clicking on the message in the Subject Window and selecting "Move to 
Folder" or "Copy to Folder".

Mozilla Thunderbird

Mozilla Thunderbird has been around a few years now and has evolved into an 
awesome desktop e-mail application. Below are a few features from the 
Thunderbird website.

Advanced Folder Views

Thunderbird 2 offers a variety of ways for you to organize and display your 
folders, whether by favorites, recently viewed or folders containing unread 
messages. As always, you can also set up RSS and newsgroup folders to stay on 
top of news and your interests. Thunderbird 2 also allows you to maximize your 
message view pane by opting for a folder drop down menu instead of the 
traditional sidebar.

Message Tagging

Thunderbird 2 allows you to "tag" messages with descriptors such as "To Do" or 
"Done" or even create your own tags that are specific to your needs. Tags can be 
combined with saved searches and mail views to make it easier to organize 
email.

Message History Navigation

Thunderbird 2 offers message history navigation that allows you to click 
"forward" and "back" much like in your Web browser. You can now quickly toggle 
between messages and folder views.

http://en-us.www.mozilla.com/en-US/thunderbird/features.html


Improved Search

Thunderbird 2 features a find as you type pane that speeds up searches within 
displayed messages. Thunderbird also offers quick search, which starts showing 
search results as soon as you start typing in search terms.

Stay Informed

Thunderbird 2 has been updated to provide more informative and relevant 
message alerts containing sender, subject and message text for newly arrived 
messages. Folders provide a pop up summarizing new messages in that folder.

Easy Access to Popular Web Mail Services

Thunderbird 2 makes it even easier to integrate and use various Web mail 
accounts from one Inbox. Gmail and Mac users can access their accounts in 
Thunderbird by simply providing their user names and passwords.

Phishing Protection

Thunderbird protects you from email scams which try to trick users into handing 
over personal and confidential information by indicating when a message is a 
potential phishing attempt. As a second line of defense, Thunderbird warns you 
when you click on a link which appears to be taking you to a different Web site 
than the one indicated by the URL in the message.

Cutting out the Junk

Mozilla has updated Thunderbird’s popular junk mail folders to stay ahead of 
spam. Each email you receive passes through Thunderbird's leading-edge junk 
mail filters. Each time you mark messages as spam, Thunderbird "learns" and 
improves its filtering so you can spend more time reading the mail that matters. 
Thunderbird can also use your mail provider's spam filters to keep junk mail out 
of your Inbox.

Open Source, More Secure

At the heart of Thunderbird is an open source development process driven by 
thousands of passionate, experienced developers and security experts spread all 
over the world. Our openness and active community of experts helps to ensure 
our products are more secure and updated quickly, while also enabling us to take 
advantage of the best third party security scanning and evaluation tools to 
further bolster overall security. Thunderbird’s update system checks to see if 
you’re running the latest version, and notifies you when a security update is 
available.



Outfit Your Inbox

Thunderbird users can increase Thunderbird’s functionality and appearance 
using hundreds of add-ons. A Thunderbird add-on can let you manage contacts, 
place voice over IP calls, listen to music, and keep track of birthdates all from 
your Inbox. You can even change the appearance of Thunderbird to suit your 
tastes.

Message Templates

Thunderbird 2 allows you to easily set up message templates to save you time – 
especially if you have to send the same mail message repeatedly.

Add-ons Manager for Extensions and Themes

The new Add-ons Manager improves the user interface for managing extensions 
and themes, making it even easier for you to customize Thunderbird 2. Install, 
uninstall, enable and disable your add-ons in a single place.

As you can see, Thunderbird has enough features to satisfy just about everyone. 
Now that you know a little about this wonderful application, lets move on to set it 
up. You can find Thunderbird by going to the menu.

Menu -> Internet -> Mail -> Mozilla Thunderbird

The first time you open Thunderbird you will see a window like the one below:



Fig. Import Wizard

In this window you can choose to import your mail, address book, preferences, 
and account settings from another e-mail client, if you have one. If Thunderbird 
detects any other e-mail clients it should list them in this window. Simply choose 
which one you want to import from and click Next.

If you chose one, the next window you would see would inform you if the 
importation was successful or not. If it was a success, then you would click Next. 
This will bring up the next window which looks like the one below:



Fig. Account Wizard

The Account Wizard is where you can setup your e-mail account(s), RSS news 
feeds, Newsgroup accounts, and even use Thunderbird to manage your Gmail 
account locally. As we did in KMail earlier, we will be setting up a POP3 e-mail 
account. If you need guidance setting up one of the other types of accounts there 
is plenty of answers in the "Help" tab located at the top of the window or at the 
Mozilla Thunderbird website. Choose "Email account" as in the figure above and 
then click Next.



Fig. Identity

Our next window will be where we establish our identity. In the box next to "Your 
Name" you need to type in the name that you would like others to see when they 
receive mail from you. The next box is the one where you will enter your e-mail 
address. When you have finished, click Next.



Fig. Server Information

This next window is where you will enter names of the servers that will fetch 
(pop) and send (smtp) your mail. You should have received this information when 
you set up your ISP account. If not, you can ask your ISP for this information. 
Under "type of incoming server", click on "POP." In the box next to "Incoming 
Server"  type in the name of your incoming server. This will usually be "pop-
server" and then the address of your ISP. 

Now we need to check the box next to "Use Global Inbox." Doing this will save 
your incoming mail on your harddrive which will allow you to work with your 
mail offline. This will be especially important to those of you on dialup 
connections. The last thing we need to do in this window is enter the name of 



your outgoing server. Type the name in the box next to "Outgoing Server." As 
with the pop-server above, the server name will usually be smtp-server and then 
the address of your ISP. When you have finished, click Next.

Fig. User Names

In this next window, as you can see above, you will need to enter your incoming 
and outgoing user names. In most cases these will be the same. After entering 
these, click Next.



Fig. Account Name

In this window you need to name this account. As you can see in the window 
above, you can name it anything you like. For people who use  different accounts 
for different aspects of their lives, this is where you can name it for whatever 
purpose you will use this e-mail address. After entering the name you prefer, 
click Next.



Fig. Congratulations

As the window above says, Congratulations! This page displays all of the 
information that you have entered in the last few windows. This is your 
opportunity to review the information and check for any errors. If everything 
looks good, go ahead and click Finish.



Fig. Processing

When you clicked Finish, the window above will appear and when the processing 
is finished it will ask you for your password. Enter your password and if you want 
to, check the box that will save your password. Press the Enter (Return) key on 
your keyboard and you will then receive any mail that you have on your mail 
providers server.

Using Mozilla Thunderbird



The default startup screen has three main sections:

left panel displaying mail boxes and folders
right main mail display panel
top panel containing the main menu bar and buttons

The left panel displays in a tree-directory format the email accounts that have 
been configured for the system and the mailboxes under it. The Local section 
contains the  folders and messages that are not from any of the accounts created 
and associated with an Internet email account and thus considered local to the 
system. Note that this includes any unsent mail messages.

Reading Mail

To read any email in your Inbox, select the Inbox folder under the desired mail 
account in the left panel. A list of the messages in your Inbox will be displayed in 
the top part of the right panel showing the email sender and subject header. To 
view the mail content click on the desired message in the top right panel and the 
message body will be displayed in the bottom right panel. Scroll as required to 
read the entire message.

Composing Mail

To compose a new email click on the Write button on the top menu. Alternatively 
you can also click Message on the menu bar and choose "New.""Compose 
(Ensure that you have selected the appropriate email account on the system by 
clicking on the appropriate account name in the left display panel.)



Fig. Composing Mail in Mozilla Thunderbird

The From field is automatically filled in for you from the email address you 
provided in the setup for the account currently being used.

The To field has to be filled in with the email address (es) of the recipient(s). 
Highlight a name from your address book and click on the "Add to To" button and 
it will show up in the To window. You can also double click a name to accomplish 
the same thing. Repeat this process as many times as necessary.

The other email header fields like Cc and Bcc can be selected by clicking on the 
To field button.

The Subject field should also be filled in with an appropriate subject header. You 
should avoid being too verbose for the subject header.

The mail message body can be entered in the right bottom panel provided and 
any file attachments can be added by clicking on the Attach button at the top and 
then selecting the file.

Sending Mail



After composing the email, you can either send it off immediately if you are 
already online, send it later, or keep it as a draft to be edited later.

To send it off immediately select the Send button. If the message was sent 
successfully it will be stored in the Sent folder.

To send it later, select from the main menu at the top,

File -> Send Later

The message will be stored under the Unsent Messages in the Local Folders 
section. In this way you can compose all the emails first and store them before 
sending them all in one go. Later on you can send all the unsent messages by 
selecting from the main menu at the top,

File -> Send Unsent Messages

This method of sending is especially useful if you are on a dial-up Internet 
connection where you can compose the messages offline and then dial-up later to 
send the messages.

To save it as a draft, select from the main menu at the top,

File -> Save As -> Draft

The email message will be saved in the Drafts folder under the current account 
section. Later, to edit the saved draft, select the Drafts folder under the account, 
click on the draft message to edit that is being displayed in the top right panel 
and select from the top menu,

Message -> Edit Message As New

After editing the message you can send it off as discussed above.

Receiving Mail

To receive mail, click on the Get Mail button at the top. When prompted, enter 
your email password (POP3 password) and the email will be downloaded from 
your Internet mailbox and stored into the Inbox folder. Of course you will have to 
be online to perform this.

Deleting Mail

To delete mail messages, select the folder in which the messages are stored in, 
and in the top right display panel where the list of messages are displayed, select 
a message by clicking on it and then click on the Delete button at the top.



The deleted mail is moved to the Trash folder in the account currently being 
used. To permanently delete them you can either delete them from the Trash 
folder or click on the Trash folder, and from the main menu at the top, select,

File -> Empty Trash

You can also right click on the trash folder and choose Empty Trash.

Folders

The various folders allow you to organize your email so that you can group and 
file them under appropriate folders. By default, when you create a new mail 
account, the Inbox, Trash, Drafts, and Sent folders are created automatically for 
you. To create a new folder perform,

File -> New -> Folder

You can file or move your messages from one folder to another by clicking on the 
list of messages displayed in the top right panel when the source folder is 
selected and dragging and dropping them into the destination folder in the usual 
manner.

Account Configuration

You can customize your account email settings by selecting,

Edit -> Account Settings



There are several important settings which you should be aware of.

Account Settings

In this main configuration screen, you can configure your name, Internet email 
address and organization name to use as well as the account name which refer to 
these settings under Thunderbird.

In particular, the "Compose messages in HTML format" box should not be 
checked if you want to compose and send your email messages using just plain 
text. Optionally, you can leave the box checked and when you send it you will see 
a box that gives you the option to send it as plain text.

Server Settings

Here you can configure the name of your POP3 mail server. You can also 
configure whether you want the mail to be deleted from the POP3 server after 
downloading them into your computer. Usually you will want them to be deleted 
and so you should ensure that the "Leave messages on server" box is not 
checked.

Outgoing Server (SMTP)

This is where you can configure the outgoing mail server which will process your 
outgoing mail.

All other Configuration

The account configuration affects only the account in question to enable you to 
configure multiple email accounts each with possibly its own servers. The global 
configuration affects the entire mail subsystem. To access the global 
configuration, select,

Edit -> Preferences

Under this configuration, you can set global preferences which will affect all the 
accounts configured by you in Thunderbird. These will include the look and feel 
of Mail itself, the way messages are displayed, format for sending etc.

Chapter 10 – Using the Open Office Suite

Introduction

OpenOffice.org (OOo) is a complete office suite, featuring a word processor 
(Writer), a spreadsheet application (Calc), and presentation software (Impress). 
Besides these fundamental office applications OOo also includes a vector 



drawing tool (Draw), allows database access, allows the publishing of documents 
in the Portable Document Format (PDF) and presentations in the Flash (SWF) 
format!

The OOo package is almost completely inter-operable with the Microsoft Office 
suite.

Getting around the package

As a first stop for information, it is important to know how the Help system 
works. To get help:

Help -> OpenOffice.org Help

Fig. OO Help window

The search function is very useful, and pay attention to the Navigation Pane on 
the top left side of the window (where you can get help for the individual 
components in OpenOffice.org).

Setting up OpenOffice.org preferences so that it works the way you want it to is 
significant. The entire controls for this are available at:

Tools -> Options



Fig. Options Window

Here you can setup settings like the default measurement units, font 
substitution, language types and many more options. Saving a document 
automatically is not setup by default, so turning this feature on might be helpful: 
you find it at the Load/Save option, under the General sub-section.

There are two important toolbars to know:

Main toolbar – this is typically located right below the menus, and contains items 
like new document, save a document, exporting to PDF, copying & pasting, as 
well as access to the Navigator, Stylist, and Gallery.

Object toolbar – this is right below the main toolbar, and has access to font 
control, and other attributes of objects.

Writer

This is a powerful tool for creating professional documents, reports, newsletters 
and so on. It is a word processor that allows easy integration of charts and 
pictures, as well as other OpenOffice.org-compatible documents. It can create 
everything from a simple letter to books, with professional layouts, and the use 
of styles.

Start it from the Main Menu by, 

Main Menu -> Office -> Word Processors -> OpenOffice.org Writer



Fig. OpenOffice.org Writer

You are now presented with the word processing portion of OpenOffice.org and 
the interface is similar to other word processing tools available. Rather than 
providing guidance throughout the entire package, we will just concentrate on a 
few tasks at hand.

Common Functions

Functions of the word processor can be controlled via the toolbars located at the 
top of the screen. On the first row, file actions like opening and saving files can 
be performed, while on the second row, changing the font, size, and style (bold, 
underline, or italics) are located there.

They can also be controlled by the menus that are common through packages:

File -> New -> Text Document - creates a new empty, untitled document for you 
to work on.

File -> Open - opens the selected file.

File -> Close - closes the document you are working on. If changes have been 
made since your last save, you will be prompted to save or discard those 
changes.

File -> Save - saves the document you are currently working on.

File -> Save As... - saves an updated version of a document in a different 
location, with a different name, from the previously saved version.

Common Operations



For operations while writing, it is common to want to select a lot of text, copy it, 
maybe cut it from its current location and paste it elsewhere, or even undo an 
action. All this is possible with the office suite, and such options are available at 
the Edit menu. A few common options are:

Fig. Common operations

To copy text: select the text with the mouse, then select Edit -> Copy. Now the 
selected text is kept in memory for use elsewhere.

To paste text: find the spot where the text needs to be placed, place the cursor 
there, and then select Edit -> Paste.

To cut text: this means that the selected text will be removed from the current 
location and kept in memory, to be placed elsewhere. Doing this is exactly like 
how a copy should be performed, except select Edit -> Cut instead.

To undo an action: Select Edit -> Undo. It will display the command that it is 
undoing at the moment.

By browsing the menu, there are also keyboard shortcuts located next to it. Once 
more proficient use of the package occurs, it is much quicker to use keyboard 
shortcuts like Control+C for Copy, and so on.

Formatting

Formatting text is as important as writing the text, and Writer provides many 
formatting options, including the Stylist. Individually, you can also format the 
character (current selected item, or even a whole word), the paragraph, or even 
the page.



Fig. Part of the Formatting toolbar (Writer)

Some of the quick format options include bold, italics and underline. These 
options are available at the toolbar at the top of the screen.

Text alignment plays a large role in controlling how portions of the document will 
look. For example, an address field at the top of your letter will have such details 
right-aligned, while the body and rest of the base text will be left-aligned. This is 
all controlled by the four-icons that are located next to the bold/italics/underline 
icons, providing such options as: right-align, centre-align, left-align and justified. 
When text is justified, it looks exactly like what you're reading now! (a more 
professional end-to-end stretch of the text.)

Let's switch to the end of the toolbar, and notice that the options there including 
providing a paragraph background – which is good for highlighting a paragraph 
or several paragraphs of text, in colours that you choose. You can also highlight 
text (like you would with a highlighter and paper) and change the font colours all 
with the icons there.

Aligning text by indenting it is also another feature available as part of the object 
toolbar. Left/right alignment of text is provided, and if text is already entered and 
you want to left-align it, selection of text (or having the cursor at the paragraph) 
must happen first, before text is indented.

Those were just quick controls. To get full control, using the Format menu is 
ideal. Controls are more varied here.

Fig. Format Menu



Styles

Consistency throughout a document is important. It was earlier said that writing 
books using OpenOffice.org is possible. So there must be a way to handle long 
and large documents in a consistent fashion, with similar fonts for headings, sub-
headings, text, and other attributes within a document.

OpenOffice.org includes a powerful feature known as styles, and this is accessed 
via the Stylist (you can access this by hitting the F11 key, or clicking its icon on 
the main toolbar). Notice the floating window, which is most likely active at the 
"Default" style. By right-clicking on the style, there are options to modify the 
style, or create new custom ones.

By going to the modify option, the style can be customized via many varying 
attributes including spacing, alignment, font, emphasis, colour and many more. 
Once suitable styles have been pre-defined in the document, they can be used on 
existing text just by selection, and double-clicking on the style name.

Just a little bit more...

Now that the gist of the Writer package has been covered, there's just a little 
more to know.

Writer has a built-in spell checker. This can be accessed via:

Tools -> Spellcheck

The option to auto-spellcheck means that while typing, Writer will dynamically 
check your spelling, and if it detects an error, it will output a red-line at the 
bottom of the misspelled word. Keep in mind that the spell checking is based on 
the current language that is in use. This can be changed via:

Tools -> Options -> Language Settings -> Languages

Accessing word counts in the document is different from most other packages on 
a default install of OpenOffice.org (this can differ with several Linux 
distributions' offerings):

File -> Properties -> Statistics

It is under the Statistics tab that the word counts and other relevant document 
counts are based. On certain vendor modified distributions of OpenOffice.org, 
going to the Tools -> Word Count menu will allow the Statistics dialogue box to 
be displayed automatically.

The AutoCorrect (Tools -> AutoCorrect) options have replacement tables (so that 
CDs really are valid, and will not be changed to Cd, for instance). There are also 



word completion options (very useful, as the software starts thinking for you) and 
settings to make them more user-friendly.

The Navigator is a yet another useful tool (get this via hitting the F5 key or 
clicking its icon on the main toolbar), especially when dealing with larger 
documents. It supports jumping to bookmarks, notes, any particular object, and 
even creates a table-of-contents on the fly, based on the styles that are being 
used.

Calc

This is the spreadsheet component of the OpenOffice.org package and contains 
many useful features, including an array of functions and plenty of charting 
options. It is fully inter-operable with Microsoft Excel, though the function 
separators differ in the two packages.

Fig. OpenOffice.org Calc

To start this, it is available via 

Main Menu -> Office -> Spreadsheets ->OpenOffice.org Calc

or if you already have an existing window of OpenOffice.org open, 

File -> New -> Spreadsheet.

Spreadsheets contain many rows and columns, and each row and column 
combination is called a cell (like A1, B4, and so on). Upon inputting text into a 
cell, you might realize that the text is wider than the cell allows for – this can be 



re-sized via right-clicking the cell, and selecting the Format Cells option. There 
under the Alignment tab, selecting Line Break is what is required.

Formatting

Like other parts of OpenOffice.org, Calc also comes with the Stylist. But let's get 
around to understanding the various differing formatting options available in this 
component of the package.

If there is some information that you have already created and the area should 
be formatted, one particular quick and easy option is to use the AutoFormat 
function available in Calc. This is done after selecting the area then:

Format -> AutoFormat

These are pre-defined styles that are available in Calc, and if you have created 
your own particular style, you can add them into your new AutoFormat.

In the object toolbar, there is an option to set the font colour within the cell. 
There are also options to increase/decrease the indents within a cell, and in the 
image below, controls for enabling:

Currency
Percentage
Add/Remove significant decimal places

Fig. Part of the Object toolbar (Calc)

These are quick controls, and accessing them is as simple as clicking the icons 
that represent them, and automatically the cell will be formatted as stated. Not 
only can Borders be set easily, and cell backgrounds too, but the alignment of 
text within a cell can also be set. This can be either as a top aligned, center 
aligned, or bottom aligned.

Now that most of the formatting options are known, it is easy to apply Styles to 
the spreadsheet. Bring up the Stylist by hitting the F11 key, and you'll notice that 
cell styles (that control all elements, including formatting) and page styles can be 
set (the latter controlling margins, headers/footers, and borders).

Spreadsheet basics

There are a few points to note when using a spreadsheet. One of them is that 
calculations are performed in a left-to-right format, with algebraic ordering 
rules. This means it deals with brackets ("()") first, then division ("/"), 
multiplication ("*"), addition ("+") and finally subtraction ("-").



When applying calculations, keep in mind the range of included cells. When 
using a function like =SUM() and using the argument =SUM(A1:A4), it means it 
looks for the sum of the cells A1, A2, A3, and A4. These operations can also be 
performed on non-consecutive cells, so, =SUM(A1;A4;A7) just executes the sum 
of cells A1, A4 and A7. 

If you have used Excel before, it would be relatively common to use a comma 
(",") as a separator character between the parameters, however, with 
OpenOffice.org Calc, the separator character is a semi-colon (";"). So for the 
function to validate correctly, an expression such as =IF(B3>0;A1-A2;A1+A2) is 
correct (as opposed to replacing the ";" with ",").

Building functions

To perform calculations, spreadsheet makes use of functions. Common functions 
include =SUM() for summation, =AVERAGE() for the average value of cells, and 
so on. As an aid to the novice user, OpenOffice.org provides a Function AutoPilot. 
This is a wizard to help build formulas, and find problems with existing 
expressions.

Fig. Function AutoPilot Button

Located next to the universal sum function, is the Function AutoPilot. If you click 
on it, a pop-up dialogue appears.

In the Functions tab, you can filter viewable/accessible functions via category, 
and the option to choose a function is shown. Use your mouse to choose a 
function that you plan on using.

Once the correct function is selected, and the action that it performs is agreeable 
(it is displayed on the right of the dialogue), select Next to move on.

Now you are allowed to input numbers. Assuming the AVERAGE function was 
chosen, in the number 1 field (for example), there are options to either enter a 
function or select a range of cells.

Use select a range of cells and now a different dialogue pops up and you can use 
the mouse cursor to select a range of cells. Click on OK, and you're done.

That is a very easy way to build a formula, which requires no prerequisite 
knowledge about what formulas exist in Calc.

Sorting



A big part of dealing with spreadsheets involves a lot of sorting and filtering of 
data. To sort a dataset, selecting the active cells, then clicking 

Data -> Sort

This will produce a pop-up dialogue that has options for sorting the data based 
on the columns present, as well as if the data should be ascending or descending.

Charting

Converting data into information is a process usually accomplished well by 
creating graphs and charts. It is a lot easier to infer based on visual graphics, 
rather than lots of numbers. Calc provides a charting wizard that will allow this 
to be automated rather easily, with a lot of predefined settings.

Select the cells that are to be charted, and then go to Insert -> Chart.
The range is pre-selected, and certain options are provided (like where the 
resulting chart is); just leaving the pre-selected options will be good for the 
exercise. Click Next.

A type of chart is to be chosen. Common charts include pie chart, line graphs, or 
even bar graphs, it all depends on the information being represented.
Select the defaults, and create a chart. (You should now see a bar chart created).

Now that a chart has been created, it is not static in the sense that it cannot be 
edited, you can control each and every aspect of how the chart looks. Double-
click the chart, and you will now go into edit mode. Notice the toolbar by the left-
hand side of your screen has changed? This is in direct response to it being in 
edit mode, and a lot of properties can be changed here.

There are plenty more features, like data filtering, scenario creation, and goal 
seek, which once you get more advanced with spreadsheet know-how, you will 
end up making use of.

Impress

No office suite is complete without a presentation piece, and OpenOffice.org 
shows its colours with Impress, the presentation piece of the suite. To start it, it 
is available at 

Main Menu -> Office -> Presentations ->OpenOffice.org Impress 

or if you already have an OpenOffice.org window open, its available at 
File -> New -> Presentation.



Fig. OpenOffice.org Impress

Unlike other components of OpenOffice.org, when you start Impress, you are 
presented with a Presentation Wizard to start creating your presentation. This 
gives you options to start a presentation with an empty template, or even with 
one of the pre-defined templates. A preview dialogue is available, and once all 
options are selected (and Next is clicked, to move on), you get a basic 
presentation.

Fig. Impress Wizard for a new presentation

After  choosing  your  background,  click  on  Create  and  you  will  see  the 
Presentation Main Page as seen below:



Fig. Presentation Main Page

Template Management

If a big portion of time is going to be spent giving presentations, its very 
professional to have the presentation look like each other, in the form of a 
template (same logo position, copyright notices, etc...). Once a template is 
created (or downloaded from the Internet), you manage templates via the:

File -> Template -> Organize

Slide Design

A quick way to get slides done is via the Presentation buttons located at the top 
right of the window:

Fig. Slide Buttons

This provides a pop-up menu option that allows you to insert slides, or even 
modify the slide layout of the current slide.

Views

There are several views in Impress, and some have over-lapping names, but with 
different functionality. At the top of the center screen, you'll notice five buttons 
that look like what you see below.



Fig. View Buttons

The five options for workspace views are:

Normal view – default, for slide design.
Outline view – overlook of the presentation.
Notes view – add speaker notes.
Handout view – how handouts get printed.
Slide Sorter view – birds eye view to add, change, switch slides around.

All the views can also be accessed via: View

Master Views are supported and to access this view, go to: View -> Master and 
then choose the one you want. You can have master views of all workspace views 
(i.e. a master view of the slide itself, notes, and handouts). The Layer view allows 
layering of slides (adding and removing), and layers can be non-printing or non-
displayed on screen, but printing only.

Jazzing up the presentation

Objects, like video, Java applets, music, and even other graphics can be added 
(embedded) to a presentation very easily. To perform this, the following menu is 
useful:

Insert -> Object

Keep in mind that OpenOffice.org will only play content provided all relevant 
plug-ins are installed. For sound playback, it assumes an already configured 
sound-card, otherwise it will not work.

Effects are another supported feature in Impress and consist of things like slide 
transitions, mouse-driven bullet-points, and even drawing animations. To get to 
the effects pop-up, click on Slide Show on the Navigation Toolbar.



Fig. Slide Show Options

Performing slide transitions are also accessed via the effects menu. However, to 
create animations, the menu is:

Slide Show -> Custom Animation...

Here, simple animations can be created, like making your text move from side to 
side and fade in and out. This is done simply by clicking on Custom Animation..., 
highlight the part of your text that you would like to animate and then click 
"Add.." from the window on the right. This will create a popup window like the 
one seen below:



Fig. Custom Animations Window

Now you simply choose an option from each of the 4 tabs in the window above 
and then click on "Play" from the window on the right to see the effect you 
created.

Conclusion

OpenOffice.org has the ability to be a very useful software package. It includes 
very powerful, free alternatives to satisfy average office suite requirements. As 
this is only scratching the surface, there are plenty more resources available out 
there, so please, use the available documentation to its fullest.
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